postgresql dblink not working in FC5

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Recently, I upgraded one of my servers to FC5 from FC4. This upgrade also upgraded postgresql to 8.1.3. The upgrade was flawless. Unfortunately, I cannot get dblink to work in postgresql. I created two fresh databases and tried... still no luck. I keep getting the following error:
bulbulbo=# select dblink_connect('hostaddr=127.0.0.1 dbname=bulbulfo
user=bulbul password=password');
ERROR:  could not establish connection
DETAIL:  could not connect to server: Permission denied
       Is the server running on host "127.0.0.1" and accepting
       TCP/IP connections on port 5432?

My pg_hba.conf is as follows:
----------------------
local   all         all                               ident sameuser
# IPv4 local connections:
host    all         all         127.0.0.1/32          password
host    all         all         192.168.0.0/24        password
host    all         all         10.1.2.0/24           password

# IPv6 local connections:
host    all         all         ::1/128               sameuser
--------------------

The error seems to be like client authentication error. I researched and found that the message "could not establish connection" seems to defined in dblink.c, and it gets triggred when it is unable to create connection to the database. I though this may be happening because libpq is not working properly. So, I compiled a simple program, written in C, that uses libpq and it seems to work fine.
I have kind of hit the roadblock. Any help would be appreciated.

Thanks

Manish


"An informed citizenry is the bulwark of a democracy"
http://www.SUNITI.org : Self-governance for an informed citizen



[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux