Re: Slightly OT - rpm -bb problems

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Paul Howarth wrote:
Mark Haney wrote:
I'm trying to build a nagios RPM from source, not on Fedora, but on RHEL AS 2.1, but when I run 'rpm -bb nagios.spec' from the /usr/src/redhat/SPECS directory it fails with a reply:
nagios.spec: No such file or directory


I don't think this is anything more than something I'm missing as far as building the RPM goes. Anybody have any ideas? Is it because it's RHEL and not Fedora? Or is it something simple?
It means you haven't put your spec file nagios.spec in the
/usr/src/redhat/SPECS directory.
Are you writing the spec yourself or using someone else's?

Is RHEL 2.1 so old that it still uses "rpm" rather than "rpmbuild" for package-building btw?
Paul.

The spec file is one from DAG's repository for nagios. There's not a latest binary for nagios built for RHEL 2.1. When I ran rpmbuild I get a 'command not found' error. The spec file is in the correct location, could it be I need the RPM devel package?


--
Interdum feror cupidine partium magnarum Europae vincendarum

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux