Re: Rhythmbox and mp3 files

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 2006-01-01 at 10:57 -0700, Craig White wrote: 
> On Sun, 2006-01-01 at 08:53 -0800, Gerhard Magnus wrote:
> > I've been trying to get the music player Rhythmbox to play mp3 files.
> > I've followed the instructions in the FC4 installation notes
> > (http://stanton-finley.net/fedora_core_4_installation_notes.html) that
> > include the following:
> > 
> > "Rhythmbox (Music Player) is the default music player in FC4 but does
> > not come with MP3 support out of the box because of patent issues. To
> > enable MP3 support for Music Player configure apt and synaptic as
> > described above. In Synaptic click on the "reload" icon to update your
> > package list. Find the gstreamer stuff and click in the checkboxes (then
> > click "Mark for installation") for each of "gstreamer",
> > "gstreamer-plugins", "gstreamer-plugins-extra-audio", and
> > "gstreamer-tools". Click the "Apply" button in Synaptic. You should now
> > have MP3 support in Rhythmbox (Music Player)."
> > 
> > After doing this, Synaptic shows gstreamer (0.8.10-1) gstreamer-plugins
> > (0.9.8-9), gstreamer-plugins-extra-audio (0.8.8-2.2.fc4), and
> > gstreamer-tools (0.8.10-1) all marked as installed.
> > 
> > Any suggestions as to how to proceed?  Do I need to install more
> > "gstreamer stuff"?  Googling various combinations of "gstreamer",
> > "rhythmbox", and "mp3" has left me totally confused as to why this mp3
> > work-around... isn't working.
> ----
> works for me - I can't get it to play aac/m4a files but that's another
> matter...
> 
> # rpm -qa|grep gstreamer
> gstreamer-plugins-extra-video-0.8.11-0.lvn.2.4
> gstreamer-tools-0.8.10-1
> gstreamer-ffmpeg-0.8.7-1.2.fc4.rf
> gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4
> gstreamer-0.8.10-1
> gstreamer-plugins-0.8.8-9
> 
> does that look similar to what you have going on? (perhaps you might not
> have gstreamer-ffmpeg but that has nothing to do with playing mp3 files.

[email protected] Sun Jan 01 12:54:45
[203] /home/magnusg $ rpm -qa|grep gstreamer
gstreamer-devel-0.8.10-1
gstreamer-plugins-0.8.8-9
gstreamer-plugins-extra-audio-0.8.8-2.2.fc4
gstreamer-0.8.10-1
gstreamer-plugins-devel-0.8.8-9
gstreamer-tools-0.8.10-1

Assuming (1) I don't need gstreamer-ffmpeg-0.8.7-1.2.fc4.rf or
gstreamer-plugins-extra-video-0.8.11-0.lvn.2.4 to get Rhythmbox to play
mp3 files and (2) the presence of gstreamer-plugins-devel-0.8.8-9 in
addition to our common gstreamer-plugins-0.8.8-9 isn't affecting
anything adversely, then the crucial difference seems to be that I have
gstreamer-plugins-extra-audio-0.8.8-2.2.fc4 installed while you are
using gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4

I found gstreamer-plugins-extra-audio-1.8.11-0.lvn.2.4.i386.rpm on the
"extra audio plugins for GStreamer" website
(http://rpm.livna.org/fedora/4/i386/RPMS.lvn/repodata/repoview/
gstreamer-plugins-extra-audio-0-0.8.11-0.lvn.2.4.html) and downloaded
it.  Then:

[email protected] Sun Jan 01 13:12:42
[206] /home/magnusg $ rpm -ivh *.rpm
warning: gstreamer-plugins-extra-audio-1.8.11-0.lvn.2.4.i386.rpm: Header
V3 DSA signature: NOKEY, key ID a109b1ec
Preparing...                ###########################################
[100%]
        file /usr/lib/gstreamer-0.8/libgstfaad.so from install of
gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4 conflicts with file from
package gstreamer-plugins-extra-audio-0.8.8-2.2.fc4
        file /usr/lib/gstreamer-0.8/libgstgsm.so from install of
gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4 conflicts with file from
package gstreamer-plugins-extra-audio-0.8.8-2.2.fc4
        file /usr/lib/gstreamer-0.8/libgstlame.so from install of
gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4 conflicts with file from
package gstreamer-plugins-extra-audio-0.8.8-2.2.fc4
        file /usr/lib/gstreamer-0.8/libgstmad.so from install of
gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4 conflicts with file from
package gstreamer-plugins-extra-audio-0.8.8-2.2.fc4

So, I deleted package gstreamer-plugins-extra-audio-0.8.8-2.2.fc4 and
installed gstreamer-plugins-extra-audio-1.8.11-0.lvn.2.4.i386.rpm
successfully:

Rhythmbox still wouldn't work.  So, just in case, I deleted
gstreamer-plugins-devel-0.8.8-9 -- still to no effect.  Here are my
current gstreamer packages:

[email protected] Sun Jan 01 13:35:48
[217] /home/magnusg $ rpm -qa|grep gstreamer
gstreamer-plugins-extra-audio-0.8.11-0.lvn.2.4
gstreamer-devel-0.8.10-1
gstreamer-plugins-0.8.8-9
gstreamer-0.8.10-1
gstreamer-tools-0.8.10-1

Any suggestions as to how to proceed?


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux