sigsegv after several days running fine

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I have a fedora box that was upgraded from 7.1.  After several days of
running fine, mozilla and up2date seg fault on launch sofar the only
ones that I have found that do. mplayer and xclock do not. a stacktrace
shows a mmap call failing.  I have exited changed runlevels to 3 from 4
( we auto start a display app on runlevel 4) and I cannot figure out
what to do to fix it short of a reboot.  I ran into mozilla segfaulting
as I was setting up this box and a reboot always fixed it and am
assuming that it will again.

The machine is still in this state and I would like to know what I need
to at least capture enough information to allow the gurus to find the
bug.

I am going to file a bug but though I would post here first to see if
anyone has any ideas.

What else should I do to allow for debugging?

Thanks 

Bret

here is a tail of the up2date strace out captured to a file

 [[email protected] exhibitor]# tail /tmp/up2date.trace.out 
old_mmap(0x6e1000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 8,
0x3000) = 0x6e1000
close(8)                                = 0
open("/usr/lib/libglib-2.0.so.0", O_RDONLY) = 8
read(8, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p\275\0"...,
512) = 512
fstat64(8, {st_mode=S_IFREG|0755, st_size=429760, ...}) = 0
old_mmap(NULL, 429772, PROT_READ|PROT_EXEC, MAP_PRIVATE, 8, 0) =
0x589000
old_mmap(0x5f1000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 8,
0x68000) = 0x5f1000
close(8)                                = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

here is a tail of the mozilla strace captured to a file



[[email protected] exhibitor]# tail /tmp/moz.trace.out 
open("/usr/lib/mozilla-1.4.1/plugins/libexpat.so.0", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/lib/libexpat.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20!\0\000"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=126904, ...}) = 0
old_mmap(NULL, 129828, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) =
0x2f1000
old_mmap(0x30f000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1d000) = 0x30f000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xbf52a000
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

[[email protected] exhibitor]# free
             total       used       free     shared    buffers    
cached
Mem:        109808     105776       4032          0      74656     
14776
-/+ buffers/cache:      16344      93464
Swap:       522072      15528     506544









[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux