Re: sigsegv after several days running fine

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 2003-11-30 at 16:18, Bret Hughes wrote:
> I have a fedora box that was upgraded from 7.1.  After several days of
> running fine, mozilla and up2date seg fault on launch sofar the only
> ones that I have found that do. mplayer and xclock do not. a stacktrace
> shows a mmap call failing.  I have exited changed runlevels to 3 from 4
> ( we auto start a display app on runlevel 4) and I cannot figure out
> what to do to fix it short of a reboot.  I ran into mozilla segfaulting
> as I was setting up this box and a reboot always fixed it and am
> assuming that it will again.
> 
> The machine is still in this state and I would like to know what I need
> to at least capture enough information to allow the gurus to find the
> bug.
> 
<snip>

Well, I wish I knew more about this stuff.  I was copying about 150MB
from one partition to another and everything started working again.  Is
there a feature of the vm that will clear all stuff from memory if a
process needs a bunch of memory or something?  I am assuming that for
some reason the kernel could not allocate the memory that moz and
up2date needed even though free showed memory available.  I will keep an
eye on this but since I can't easily replicate it, I will wait to file a
bug.  I cannot find anything in bugzilla that sounds like this issue. 
Has anyone else seen anything similar?

Bret




[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux