Re: irda problems + dual mouse on thinkpad

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hash: SHA1

On Monday 17 November 2003 11:46, Dexter Ang wrote:

> now when i installed fedora, only the usb mouse works. is there any way
> to get the usb to work, but still keep the touchpad/pointing stick to
> work as well? what exactly do i need to add to X's configuration?

Here are the relevant parts of /etc/X11/XF86Config that work in that very way 
on an IBM R31 here:

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "PS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

> next question... irda. i've loaded /etc/rc.d/init.d/irda. irda is binded
> to /dev/ttyS1. when i use pilot-xfer -p /dev/ttyS1 -L, i can list what
> is on my palm. this only works as root. i've already chmod'd /dev/ttyS1
> to 777, made a symbolic link to it called /dev/pilot. loaded up
> pilot-xfer -L, and, as my normal user, it says it can't bind to
> /dev/pilot. is there anything else i have to do to make it work with a
> normal account? this used to work with rh9, where a simple change of
> permissions work. i've already tried changing owner to my account, but
> it still doesn't work.

Don't really know about this, but I would try changing the owner of /dev/ttyS1 
and /dev/pilot to your normal user.  If I was feeling brave I might try to do 
cat /dev/pilot as the normal user and see if there was a more informative 
error message.

> extra question: is it appropriate for people to reply "thanks" to
> answers that work? or is it better to just leave it, saving some people
> the bother of downloading unnecessary email? thanks =)

Actually its useful information to hear that the solution fixed the problem... 
if people are searching for the same problem months or years later its useful 
to know that the proposed solution helped someone sometime.  Oftentimes the 
proposer of the 'solution' is making an educated guess and it leaves him none 
the wiser if he never hears back.

- -Andy
Version: GnuPG v1.2.2 (GNU/Linux)


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux