On Mon, 16 Jul 2007 17:02:13 +0200
Yoann Padioleau <[email protected]> wrote:
>
> potential parse error in declaration under a #ifdef.
A certain parse error, I'd say. How come nobody is reporting it?
> Signed-off-by: Yoann Padioleau <[email protected]>
>
>
> diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
> index 9674d4e..9141c37 100644
> --- a/drivers/serial/dz.h
> +++ b/drivers/serial/dz.h
> @@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE 4096
> #define DZ_WAKEUP_CHARS DZ_XMIT_SIZE/4
>
> #ifdef MODULE
> -int init_module (void)
> -void cleanup_module (void)
> +int init_module (void);
> +void cleanup_module (void);
> #endif
>
> #endif /* DZ_SERIAL_H */
I don't think these symbols are actually implemented in anything which
uses this header. If they _do_ exist then they are awfully named and
should be renamed ASAP. Or they should be made static.
However I suspect they just don't exist, and this stuff should be simply
deleted.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]