On 5/21/07, Pekka Enberg <[email protected]> wrote:
On 5/21/07, Bryan Wu <[email protected]> wrote:
> -void *dma_memcpy(void *dest, const void *src, size_t size)
> +void *_dma_memcpy(void *dest, const void *src, size_t size)
Minor nitpick: the established naming convention is two underscores, not one.
that should be marked as static now actually since the function isnt
for use outside of this file
> +void *dma_memcpy(void *dest, const void *src, size_t size)
> +{
> + size_t bulk;
> + size_t rest;
> + void * addr;
> +
> + bulk = (size >> 16) << 16;
I assume this is significantly faster on your architecture than:
bulk = size & ~0xFFFFUL;
which is more readable?
actually they should get optimized to the same thing
-mike
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]