Lots of paravirt patches from Jeremy and Zach. I think most of them have hit the list already. Mostly Xen preparation, but lots of generic cleanups Happy reviewing! -Andi - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH] [32/40] i386: kRemove a warning about unused variable in !CONFIG_ACPI compilation.
- From: Andi Kleen <[email protected]>
- [PATCH] [34/40] i386: Clean up arch/i386/kernel/cpu/mcheck/p4.c
- From: Andi Kleen <[email protected]>
- [PATCH] [35/40] i386: Now that the VDSO can be relocated, we can support it in VMI configurations.
- From: Andi Kleen <[email protected]>
- [PATCH] [33/40] i386: Allow boot-time disable of paravirt_ops patching
- From: Andi Kleen <[email protected]>
- [PATCH] [29/40] i386: map enough initial memory to create lowmem mappings
- From: Andi Kleen <[email protected]>
- [PATCH] [39/40] i386: Export paravirt_ops for non GPL modules too
- From: Andi Kleen <[email protected]>
- [PATCH] [36/40] i386: Implement vmi_kmap_atomic_pte
- From: Andi Kleen <[email protected]>
- [PATCH] [22/40] x86: deflate stack usage in lib/inflate.c
- From: Andi Kleen <[email protected]>
- [PATCH] [30/40] x86: update for i386 and x86-64 check_bugs
- From: Andi Kleen <[email protected]>
- [PATCH] [14/40] i386: add common patching machinery
- From: Andi Kleen <[email protected]>
- [PATCH] [12/40] i386: Consistently wrap paravirt ops callsites to make them patchable
- From: Andi Kleen <[email protected]>
- [PATCH] [38/40] x86: Jeremy Fitzhardinge <[email protected]>
- From: Andi Kleen <[email protected]>
- [PATCH] [19/40] i386: fix paravirt-documentation
- From: Andi Kleen <[email protected]>
- [PATCH] [18/40] i386: flush lazy mmu updates on kunmap_atomic
- From: Andi Kleen <[email protected]>
- [PATCH] [20/40] i386: Clean up paravirt patchable wrappers
- From: Andi Kleen <[email protected]>
- [PATCH] [21/40] i386: drop unused ptep_get_and_clear
- From: Andi Kleen <[email protected]>
- [PATCH] [23/40] x86_64: deflate inflate_dynamic too
- From: Andi Kleen <[email protected]>
- [PATCH] [4/40] i386: Add pagetable accessors to pack and unpack pagetable entries
- From: Andi Kleen <[email protected]>
- [PATCH] [6/40] i386: Allocate a fixmap slot
- From: Andi Kleen <[email protected]>
- [PATCH] [3/40] i386: use paravirt_nop to consistently mark no-op operations
- From: Andi Kleen <[email protected]>
- [PATCH] [1/40] x86_64: update MAINTAINERS
- From: Andi Kleen <[email protected]>
- [PATCH] [28/40] i386: Fix UP gdt bugs
- From: Andi Kleen <[email protected]>
- [PATCH] [26/40] i386: cleanups to help using per-cpu variables from asm
- From: Andi Kleen <[email protected]>
- [PATCH] [9/40] i386: rename struct paravirt_patch to paravirt_patch_site for clarity
- From: Andi Kleen <[email protected]>
- [PATCH] [11/40] i386: Fix patch site clobbers to include return register
- From: Andi Kleen <[email protected]>
- [PATCH] [15/40] i386: add flush_tlb_others paravirt_op
- From: Andi Kleen <[email protected]>
- [PATCH] [16/40] i386: revert map_pt_hook.
- From: Andi Kleen <[email protected]>
- [PATCH] [10/40] i386: Use patch site IDs computed from offset in paravirt_ops structure
- From: Andi Kleen <[email protected]>
- [PATCH] [17/40] i386: add kmap_atomic_pte for mapping highpte pages
- From: Andi Kleen <[email protected]>
- [PATCH] [25/40] i386: Convert PDA into the percpu section
- From: Andi Kleen <[email protected]>
- [PATCH] [27/40] i386: Define per_cpu_offset
- From: Andi Kleen <[email protected]>
- [PATCH] [31/40] i386: In compat mode, the return value here was uninitialized.
- From: Andi Kleen <[email protected]>
- [PATCH] [40/40] i386: Clean up ELF note generation
- From: Andi Kleen <[email protected]>
- [PATCH] [37/40] i386: Convert VMI timer to use clock events
- From: Andi Kleen <[email protected]>
- [PATCH] [13/40] i386: Document asm-i386/paravirt.h
- From: Andi Kleen <[email protected]>
- [PATCH] [7/40] i386: Allow paravirt backend to choose kernel PMD sharing
- From: Andi Kleen <[email protected]>
- [PATCH] [8/40] x86: add hooks to intercept mm creation and destruction
- From: Andi Kleen <[email protected]>
- [PATCH] [24/40] i386: Page-align the GDT
- From: Andi Kleen <[email protected]>
- [PATCH] [5/40] i386: Hooks to set up initial pagetable
- From: Andi Kleen <[email protected]>
- [PATCH] [2/40] i386: Remove CONFIG_DEBUG_PARAVIRT
- From: Andi Kleen <[email protected]>
- [PATCH] [32/40] i386: kRemove a warning about unused variable in !CONFIG_ACPI compilation.
- Prev by Date: Re: utrace comments
- Next by Date: [PATCH] [2/40] i386: Remove CONFIG_DEBUG_PARAVIRT
- Previous by thread: Re: Reiser4: Transparent compression support. Further development and compatibility.
- Next by thread: [PATCH] [2/40] i386: Remove CONFIG_DEBUG_PARAVIRT
- Index(es):