On Thu, 10 Aug 2006 09:57:22 +0200
Miklos Szeredi <[email protected]> wrote:
> Thanks Alex.
> -mm also needs s/page_cache_release/read_cache_pages_release_page/ on patch
> From: Alexander Zarochentsev <[email protected]>
> Don't let fuse_readpages leave the @pages list not empty when exiting
> on error.
> +extern void readpages_cleanup_helper(struct list_head *);
Can we think of a better name? I mean, all it does is throw away a list of
pages. The caller doesn't _have_ to be using it within the context of
read_cache_pages(). put_pages()? put_pages_list()?
And if we do make this a more generic thing, it'd be better off living in
mm/swap.c, which is really mm/mm-library-stuff.c nowadays.
> + * may be useful in foo_fs_readpages method for the page pool cleanup
> + * before exiting on error.
> + */
"/**" introduces a kerneldoc comment, but that isn't a kerneldoc comment.
It would be best to turn it into a kerneldoc comment.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Video 4 Linux]
[Linux for the blind]