> > +/*
> > + * Internally used to invert the rating, so lower is better.
> > + */
> > +#define CLOCKSOURCE_RATING(x) (INT_MAX-x)
>
> Since this is used for the plist bits, could it get a more explicit
> name?
Sure, like CLOCKSOURCE_INVERT_RATING()
> > int clocksource_register(struct clocksource *c)
> > {
> > int ret = 0;
> > unsigned long flags;
> >
> > + if (unlikely(!c))
> > + return -EINVAL;
> > +
>
> I'm not sure I understand the need for this. Is it really likely someone
> would pass NULL to clocksource_register()?
Not likely, I was just covering all possibilities.. It might be better
as a BUG_ON() actually.
Daniel
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]