On Fri, Apr 14, 2006 at 12:21:04AM +0400, Oleg Nesterov wrote:
> #define NEW_IMPROVED_HLIST_FOR_EACH_ENTRY_RCU_WHICH_DOESNT_NEED_EXTRA_PARM(pos, head, member) \
> for (pos = hlist_entry((head)->first, typeof(*(pos)), member); \
> rcu_dereference(pos) != hlist_entry(NULL, typeof(*(pos)), member) \
> && ({ prefetch((pos)->member.next); 1; }); \
> (pos) = hlist_entry((pos)->member.next, typeof(*(pos)), member))
>
> What do you think? What should be the name for it?
Justy kill the superflous argument from all hlist_for_each_entry variants
without a name change.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]