On 04/13, Christoph Hellwig wrote:
>
> On Thu, Apr 13, 2006 at 09:54:31PM +0400, Oleg Nesterov wrote:
> > >
> > > #define for_each_task_pid(task, pid, type, pos) \
> > > hlist_for_each_entry_rcu((task), (pos), \
> > > (&(pid))->tasks[type], pids[type].node) {
> > >
> > > and move the find_pid to the caller? That would make the code a whole lot
> > > more readable.
> >
> > Then the caller should check find_pid() doesn't return NULL. But yes,
> > we can hide this check inside for_each_task_pid().
> >
> > But what about current users of do_each_task_pid ? We can't just remove
> > these macros.
>
> They'd have to switch over to the new variant. There's just 18 callers
> ayway, currently, and with a patch like the one below that number firther
> decreases :)
Ok, In such a case we should first
#define NEW_IMPROVED_HLIST_FOR_EACH_ENTRY_RCU_WHICH_DOESNT_NEED_EXTRA_PARM(pos, head, member) \
for (pos = hlist_entry((head)->first, typeof(*(pos)), member); \
rcu_dereference(pos) != hlist_entry(NULL, typeof(*(pos)), member) \
&& ({ prefetch((pos)->member.next); 1; }); \
(pos) = hlist_entry((pos)->member.next, typeof(*(pos)), member))
What do you think? What should be the name for it?
Oleg.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]