Re: [PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



KAMEZAWA Hiroyuki <[email protected]> wrote:
>
> Now,
>  for_each_cpu() is for-loop cpu over cpu_possible_map.
>  for_each_online_cpu is for-loop cpu over cpu_online_map.
>  .....for_each_cpu() looks bad name.
> 
>  This patch renames for_each_cpu() as for_each_possible_cpu().
>

Sane.

>  I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
>  please confirm....
> 
>  BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
>  should be avoided, I think.

Sometimes.  Sometimes it's valid though - allocating (small amounts of)
per-cpu storage, summing up per-cpu counters (poorly), etc.

>  -#define for_each_cpu(cpu)	  for_each_cpu_mask((cpu), cpu_possible_map)
>  +#define for_each_possible_cpu(cpu)  for_each_cpu_mask((cpu), cpu_possible_map)

Nope, I'll change this to

#define for_each_cpu(cpu)	  for_each_cpu_mask((cpu), cpu_possible_map)
#define for_each_possible_cpu(cpu)  for_each_cpu_mask((cpu), cpu_possible_map)

So both are valid.  That way

a) The kernel continues to compile at each step of the patch series
   (important!) and

b) We can remove for_each_cpu() later on, after all the various
   out-of-tree usages have been converted.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux