Re: [PATCH] pcilynx.c LIndent fixes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



(I'm also sending this to lkml in case people disagree with me or I
missed something.  Should we put something like this in CodingStyle as a
warning to future Lindent users?)

Things that Lindent generally screws up on:

On Tue, Nov 22, 2005 at 02:41:38AM +0000, Jens-Michael Hoffmann wrote:

> -MODULE_PARM_DESC(skip_eeprom, "Use generic bus info block instead of serial eeprom (default = 0).");
> -
> +MODULE_PARM_DESC(skip_eeprom,
> +		 "Use generic bus info block instead of serial eeprom (default = 0).");

String handling.  I guess this is difficult to sensibly automate, but
this should really be something like:

MODULE_PARM_DESC(skip_eeprom,
		 "Use generic bus info block instead of serial eeprom "
		 "(default = 0).");

> [...]

>  static struct i2c_adapter bit_ops = {
> -	.id 			= 0xAA, //FIXME: probably we should get an id in i2c-id.h
> -	.client_register	= bit_reg,
> -	.client_unregister	= bit_unreg,
> -	.name			= "PCILynx I2C",
> +	.id = 0xAA,		//FIXME: probably we should get an id in i2c-id.h
> +	.client_register = bit_reg,
> +	.client_unregister = bit_unreg,
> +	.name = "PCILynx I2C",
>  };

That's not better :)  The structure was much more readable before the
change.  This is especially apparent with large structures.


Cheers,
Jody
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux