Re: [linux-usb-devel] 2.6.12 - USB Mouse not detected

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sunday 10 July 2005 16:42, Alan Stern wrote:
> > Beginning 2.6.12 my Wireless USB Mouse is not detected in the first
> > attempt - Meaning if I boot the machine with the mouse connected, it's
> > not detected until I disconnect the mouse and then reconnect it.
>
> That's not quite right.  Your log clearly shows the mouse was detected and
> assigned address 2.
Yeah, I shoud have worded it properly - kernel detects the device but it's 
unusable since the driver for it - USBHID wasn't loaded.
>
> >  It works fine after the disconnect-reconnect cycle. Looking at the
> > dmesg, it seems that at first time it forgets to register the hiddev
> > driver - mysteriously, it remembers the second time.
>
> Exactly.  The hiddev driver wasn't loaded the first time, which makes this
> sound like some sort of hotplug failure.  Are your hotplug and udev
> packages up to date?
I hadn't changed anything (except for the system board which failed recently) 
and it used to work fine - So I didnt suspect hotplug to be the culprit - 
another reason for not considering hotplug was it worked the second time with 
identical setup.

What's funny - I rebuilt hotplug - same version - and it works now! Probably 
it was failing for some reason the first time.

Thanks!

Parag
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux