[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to install Java/Frefox in FC6 -



On Monday 18 December 2006 07:41, Bob Goodwin wrote:
>Tim wrote:
>> On Sun, 2006-12-17 at 11:49 -0500, Ric Moore wrote:
>>> bookmark this site, it's invaluable. Just follow the steps, use cut
>>> n paste, and you'll have to right on the button.
>>> http://www.stanton-finley.net
>>>
>>> This one is a keeper, the steps for FC5 are good for FC6.
>>
They may be, but before I went to that lengthy procedure, I tried a few 
other things, and wound up using the sun package 
jdk-1_5_0_10-linux-i586.rpm
which unpacked to
jdk-1_5_0_10-linux-i586.bin
which then makes a jdk1.5.0-10 tree
and then found the plugin and copied it over the older ones in every 
plugins directory I had.
That was
ls -l jdk1.5.0_10/jre/plugin/i386/ns7/libjavaplugin_oji.so
-rwxr-xr-x 1 root root 103432 Nov  9 19:07 
jdk1.5.0_10/jre/plugin/i386/ns7/libjavaplugin_oji.so

I'm not sure which one FF is actually using, but it all is apparently 
working just fine with it copied to these locations here:
#>locate libjavaplugin_oji.so
/usr/java/jdk1.5.0_10/jre/plugin/i386/ns7/libjavaplugin_oji.so
/usr/java/jdk1.5.0_10/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so
/usr/lib/firefox-1.5.0.8/plugins/libjavaplugin_oji.so
/usr/lib/mozilla/plugins/libjavaplugin_oji.so

I believe the first one above is what OOo-2.0.4 is using as its happy with 
the install also.  I have disabled the jpackage stuff in /etc/yum.repos.d 
because that site comes and goes according to the phases of the moon or 
something.  That's rather a PITA.

>> I tried that with FC6, just a few days ago.  The Sun site had moved
>> onto Java 1.6.0, which didn't work (installed, no errors, just doesn't
>> appear to work when I tested it).  I've just had another bash, making
>> sure I got all the new paths right.  The Java test page (*) doesn't
>> work with Java 1.6.0 (no results are shown, it's blank in the test
>> part), but I don't know if that's just the test page.  I don't know a
>> site using Java to test it with, but the games I tried on the Sun site
>> didn't work.
>>
>> Today, when I tried the link from the Stanton-Finley site, Sun didn't
>> redirect me to the latest, but stayed at the release number the link
>> was intended for (1.5.x).  It's now jre1.5.0_10 instead of jre1.5.0_8,
>> so the paths in the examples to copy and paste need correcting.  That
>> done, it worked, but the test page wants to install a JRE plug in,
>> even though it's apparently working, and tells me I'm using an old
>> version.  The games apparently work (not that *I* can play them).

IMO you should have let it overwrite the older plugin.

>    *I think I made the necessary changes to a procedure** by Paul
>    Howarth that** I found,*
>    *without success.*
>
>    *I then tried the procedure described on the Sun page which offers
>    1.5.09 instead of 10*
>    *and that's no go also, I get a huge list of dependency failures,
>    normally I would work my*
>    *way through the list but I had no success finding them so far?  So
>    I will try the various *
>    *suggestions I've received this morning.  I haven't bothered with
>    Java since FC4 but in this
>    case my grandson had a game **he wanted his father to try on his new
>    Linux install.
>
>    I'm trying to wean them on to FC6.*
>
>    *Thanks, Bob*
>
>> Anybody care to make suggestions?  Stick with the old version,
>> solutions to make the current version work?  It was the "current"
>> release version I tried, not the latest, not yet release-version,
>> version.
>>
>> * Java test page: <http://www.java.com/en/download/help/testvm.xml>

Which works according to what it says there for me, but won't let me mouse 
copy the java generated portion of the test.  It also says I'm using an 
older version of java (1.5.0_10) and that I should upgrade, but when I 
goto the downloads page, all 4 links are to the 1.5.0_09 version, for 
both the x32 bit .rpm, .bin, and x64 versions of the .rpm and .bin files.  
So apparently I'm one bugfix up from that version.  I got it from 
java.com but don't recall the exact URL now.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Yahoo.com and AOL/TW attorneys please note, additions to the above
message by Gene Heskett are:
Copyright 2006 by Maurice Eugene Heskett, all rights reserved.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

Powered by Linux