Re: [FIXED -- kind of] Grub_IMAGE 'bad grub stage1 image' -- what is this telling me.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 01/12/2011 11:59 AM, William Case wrote:
On Fri, 2011-01-07 at 17:30 -0500, William Case wrote: 
Hi;

On Fri, 2011-01-07 at 16:29 -0500, William Case wrote:
Hi;

I ran firstaidkit as root and got the following warning:

Grub_IMAGE  Detected 'bad grub stage1 image'.  Fix doesn't fix.

Googled and got either way out of date messages or lots of Grub2 stuff.
I posted a question here a couple of days ago with lots of info.  Will
repost if it is helpful.

What is this firstaidkit warning telling me?
grub> find /grub/stage1
is now returning:  (hd0,0) and (hd2,0)

I don't have a (hd2,0)  but that is where grub thinks the grub.conf file
is and it works !!
BIOS changed the disk boot order automatically on me when I
disconnected /dev/sda temporarily.  The change did not show on the BIOS
boot order menu.  I had to dig three levels down in Advanced Features of
my BIOS to find the change.

Grub still doesn't recognize the chainload command.

It may well be my old Maxtor with my WindowsXP system (/dev/sda) has
died. I would just get a new harddisk except I don't want to go through
the exercise of reinstalling WindowsXP and updating everything. My
problem now is that the data and files on XP are all visible when I
mount the disk. I have no trouble mounting and browsing around
in /dev/sda. I am going to do the following as a last ditch effort:
1) Physically disconnect /dev/sdb and see if I can get WindowsXP to boot
on its own. If I can't I can be pretty sure I have an old dead disk
problem.
2) Try to rescue everything on /dev/sda with dd or a backup program and
reinstall Windows. Yes, I backed up but I am so seldom in WindowsXP that
the backup is way out of date.

If you have any other suggestions, I would be glad to hear them and try
them. This Windows disk is not critical and can wait repairing or
replacing. I hardly ever boot into WindowsXP anymore.

Hey William,

If you so seldom use WinXP you might consider trying KVM to set up a virtual machine where you can load WinXP.  There is a bug in F13 that prevents the WinXP machine from booting up but I understand that this has been fixed in F14.

Here's a quote from this mailing list that I got on the subject when I couldn't boot my new WinXP install.  I've been very busy with outside interests for a while now so I havn't had time to try this out.  Your mileage my vary.

##### BEGIN QUOTE #####
Yep: You are using f13 which does not yet have a fix for the
bug: https://bugzilla.redhat.com/show_bug.cgi?id=579348

If you follow pointers in there you can find fixes to
apply to the disk image with a binary editor, or you can
upgrade to f14 which does have the fix, or you can just
upgrade your libvirt & qemu and wot-not with the preview
release. Look in the archives for the fedora virt mailing
list for lots of info on this same topic:

http://lists.fedoraproject.org/pipermail/virt/
-- users mailing list [email protected] To unsubscribe or change subscription options: https://admin.fedoraproject.org/mailman/listinfo/users Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
##### END QUOTE #####
-- 
users mailing list
[email protected]
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux