Re: FC12 livecd-iso-to-disk woes - now suicidal

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 8 March 2010 16:58, T. Horsnell <[email protected]> wrote:
> dexter wrote:
>> On 8 March 2010 10:35, T. Horsnell <[email protected]> wrote:
>>> Hi all,
>>> I'm trying to make a USB version of the FC12 livecd.
>>> I follow the instructions at:
>>>
>>> http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo
>>>
>>> and type (as root):
>>>
>>> # livecd-iso-to-disk --format --reset-mbr Fedora-12-i686-Live.iso /dev/sdc1
>>>
>>> but the resulting USB stick just gives me 'Boot Error' when I boot it.
>>>
>>> If I use the dd method:
>>>
>>> # dd if=Fedora-12-i686-Live.iso of=/dev/sdc bs=8M
>>>
>>> it boots correctly. I ultimately want a persistent-storage
>>> area so the dd solution is no good for me.
>>>
>>> Any ideas?
>>>
>> try liveusb-creator then bugzilla :-)
>>
>> ...dex
>
> Well, I've so far tried all the suggestions (except bugzilla),
> and *nothing* works. I must be doing something wrong.
>
> On my FC9 with livecd-tools-0.17.3-1.fc9

FC9 why didnt you say :-) its definetly not going to work on FC9 you
need to upgrade syslinux I have syslinux-3.75-2.dex.fc9.i686 self
built & livecd-tools-017.2-1.fc9.i386 I havent tried building a respin
on FC9 lately because of the rpm & squashfs changes around FC11 but I
can still write useable FC12.iso usb-sticks from FC9 due to the
syslinux upgrade.

> Ive tried:
>  livecd-iso-to-disk Fedora-12-i686-Live.iso /dev/sdc1

this should have worked?
Sorry I cant see what your doing wrong from here so if you downloaded
the iso check the checksum again and give your stick a good look to.
(bootable,vfat,ext3/4,etc)

>  livecd-iso-to-disk Fedora-12-i686-Live.iso /dev/sdc (required mkdosfs -I and mkfs.vfat -I)

This is wrong in my book its always the partition and not the whole
disk i.e sdc1

>  liveusb-creator Fedora-12-i686-Live.iso
> and, thinking it might be a subtle difference in the iso structure,
> I tried the same commands with Fedora-9-i686-Live.iso
>
> They all failed with a 'Boot error'.
>
> I then moved to my newly installed and updated FC12 system, with livecd-tools-031-1.fc12.1 and tried:
>  livecd-iso-to-disk Fedora-12-i686-Live.iso /dev/sdb1
>  livecd-iso-to-disk --format --reset-mbr Fedora-12-i686-Live.iso /dev/sdb1
>  livecd-iso-to-disk --format --reset-mbr Fedora-12-i686-Live.iso /dev/sdb
>  liveusb-creator Fedora-12-i686-Live.iso
>
> These also failed in the same way.
>
> The only thing that works is 'dd if=Fedora-12-i686-Live.iso of=/dev/sdb bs=8M'
> and if it wasnt for this I would think either my memsticks or my bios were faulty.

Well if thats the case the stick & iso & bios are good?? ignore what I
said earlier reguarding checking.

...dex
-- 
users mailing list
[email protected]
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux