Re: Fedora 12 does not work after replacing the motherboard

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Tuesday, March 2, 2010, 7:17:57 AM, you wrote:

>> Hello All,
> 
>> I kindly ask for your support. On my MythTV frontend-only machine, I
>> had to replace the motherboard. The old motherboard was an ASUS P5KR
>> (Intel P35 chipset), and the newly installed motherboard is an MSI
>> P43T-C51 (Intel P43 chipset). The old MB wasn't faulty - I just had
>> to urgently use it in another machine.
>> Everything else in this system remained basically the same - CPU,
>> RAM, Video, etc. My video adapter is NVidia 8600GT made by ASUS (don't
>> remember the model exactly). I am using proprietary NVidia driver from
>> rpmfusion.
> 
>> With the new MSI MB, the system just stops responding when trying to
>> boot into graphical mode (runlevel 5), and there seem to be no errors
>> in /var/log/messages, dmesg or in Xorg.log.

<skip>

>> If I do an 'init 5' while I'm in runlevel 3, I can see Xorg starting
>> and occupying all of the CPU resources (so that my PC doesn't respond
>> to keyboard at all, and remote SSH sessions are also interrupted).
>> Again, I don't see any obvious error messages in the logs when the
>> system stops responding...
> 


> Have you rebuilt your initrd images? They possibly contain some drivers
> that your old MB needed and your new MB needs different? The easist way
> is to probably do a "yum reinstall kernel" when you are certain that the
> loaded modules you are using are correct for your system.

Oh, yes!
I think I rebuilt initrd on this machine, as I wanted to disable
nouveau (in order to use proprietary NVidia driver).

'yum reinstall kernel' returns to me:

Package kernel-2.6.31.12-174.2.22.fc12.i686 is allowed multiple installs, skipping



> 
> Do this from "init 3" mode. Then debug what's wrong with your graphical
> setup and the new MB before trying to make "init 5" your default boot
> mode again.



>> At the same time, Fedora 12 Live CD boots up fine (in Gnome) but stops
>> responding after a few minutes.


> Any idea why?

Not really... (see below)


>> I thought this could be a hardware issue. I checked the RAM with
>> memtest (well, 2 passes went without errors, then I interrupted it).
>> Then I installed Windows XP - to test if it will fail. XP worked good,
>> I installed all the drivers and noticed no stability problems at all.

> Running memtest overnight or for 24 hours would be a better test. Once
> before I didn;t see an error until the 5th iteration before it triggered
> an error.... Whether it was thermal, or bit pattern related, I never
> did figure out, I just replaced the bad RAM.

Yes, I know I need to test it for a longer period of time. I'll leave
the machine with memtest running tonight... Or ... maybe I'll leave it
with some general system stability test, not to concentrate
exclusively on RAM at this step...


>> What else should I check???
> I like to debug my X configuration using the "startx" command. That way
> I can (usually) abort the server with Ctrl-Alt-Bckspc when necessary. X
> can be a pain when it hangs the machine making it impossible to switch
> to another VC. If you can't login remotely, odds are the whole kernel
> has hung (which is bad for you with the nvidia driver in use as it
> taints the kernel, and noone here will help you debug it unless you can
> reproduce it using either the nv or nouveau drivers).

Yep, thanks for the hint!


> It might be good to see of using nouveau or nv helps you get *some*
> graphics up, even if it doesn't help your MythTV system.

Ummm... I'd also like to try it with nouveau, but I'm not sure how to
do that (I need to somehow get back the original initrd first)...


> Have you tried underclocking your system (if you can)? That might show
> some thermal problems....

Well, I'm not fond of overclocking, so I'm not sure if there's any
possiblity to underclock. BIOS settings are at their defaults (and I
have the latest BIOS version - I checked that). CPU temperature is
around 37C and chipset is around 42C which is (generally) a perfect
temperature for this kind of system. Of course there could be some
other element far from the thermal sensor that gets excessively hot.
But I didn't find anything unusual by now.



Yet, I found another evidence. I tried replacing my video adapter
(8600GT) with an older 7600GS and then with a newer GT220. In both
cases, the system started in graphical mode without any errors. So
it seems that the system works fine with any other video adapter!

I then put my "problematic" 8600GT to a couple of other machines (one
was running similar Fedora 12, and the other one - WinXP). It worked
without issues as well - I watched a movie (using VDPAU) and played a
modern game on a Windows machine. No problems at all...

So there seem to be an incompatibility between a particular MSI MB
and a particular 8600GT video adapter... Ummm...



-- 
users mailing list
[email protected]
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux