Re: expunge in evolution is no longer working-CORRECTION

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 2010-02-12 at 18:32 -0500, John Mellor wrote:
> On Fri, 2010-02-12 at 14:08 -0600, Aaron Konstam wrote:
> > On my machine expunge in evolution-2.28.2-1.fc12.i686 is no longer
> > working so the deleted messages are building up. What does one do in
> > this case to fix this problem?
> > +++++++++++++++++++++++++++++++++++++++++++++++
> > Expunge works in all the folders except Inbox, Junk and Trash.
> > Maybe it is not supposed to work in Trash.
> 
> Yeah, I have no idea why this is taking years (literally) to fix.  Its
> like the Novell dev guys are purposely sabotaging Gnome users or
> something.  The first reports that I sent in of this problem were on
> Fedora 4, and its still there and still biting an awful lot of users
> over and over again.

Not only have I never seen this, I don't recall even hearing about it,
at least in these terms, despite being on the Evo list for lo these many
years. IOW I doubt it's all that common.

Be that as it may, one thing to try is to completely quit Evo
("evolution --force-shutdown") and run the following script, which
cleans up Evo's SQL databases:

        #!/bin/sh
        
        cd ~/.evolution/mail/
        for i in `find . -name folders.db`
                do
                echo "Rebuilding Table $i"
                sqlite3 $i "vacuum;"
        done
        
BTW the OP didn't say whether his mail is on an IMAP server or not. This
could possibly be relevant.

poc

-- 
users mailing list
[email protected]
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux