Re: is suspend broken?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Peter Langfelder wrote:
> On Fri, Jan 8, 2010 at 10:05 AM, Kevin J. Cummings
> <[email protected]> wrote:
>> When I bought my laptop, it was shipped with a cubbi-suspend2 kernel and
>> the fglrx driver and ran under FC6.i386.  suspend worked for me on the
>> shipped configuration.
>>
>> When I upgraded to F9.x86_64, I no longer needed the cubbi-suspend2
>> kernel (now called tuxonice), and suspend worked really well.  I was
>> still using the fglrx video driver.
>>
>> Now that I'm running F11.x86_64, there is no fglrx (or catalyst) driver
>> for my video, and suspend no longer works for me.  There are no errors
>> listed in my pm-suspend.log, in fact, the last thing in this file claims
>> that it is "performing suspend".  However, my system never powers down
>> and never enters the suspend mode (with the flashing power LED
>> indicator).  It remains powered on.  The only way to get the system back
>> is to lean on the power button until the system powers down.  The power
>> LED is then off.  The only way to power back up is to touch the power
>> button again, and after which the system goes through a complete cold
>> start and reboots from scratch.  When it is properly suspended, I should
>> be able to touch "any" key to resume from suspend back to a running system.
>>
>> Can anyone please tell me what (obvious thing) I'm missing?
>>
> 
> Not sure if this will help, but you can try. I have a Lenovo T60 with
> some ATI graphics card and the standard radeon driver. Suspend only
> works if the system is booted with a nomodeset option. I don't quite
> recall what went wrong when trying suspend on a modesetting kernel,
> but it never worked.
> 
> BTW, as far as I remember, when suspended, the machine only wakes up
> when the laptop lid is opened - pressing keys does not wake it up.
> 
If I might offer one other thought, even with modeset, I believe changing to a 
text console and suspending from there will work to resume and to change back to 
X later. Someone showed me that as the only way their laptop worked right.

And if you are happy with nomodeset you don't care, do you?  ;-)

-- 
Bill Davidsen <[email protected]>
   "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

-- 
users mailing list
[email protected]
To unsubscribe: https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux