Re: fetchmail [FAILED] need more info [SOLVED]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Gene Smith wrote, On 01/10/2010 08:26 PM:
> When I start service fetchmail all I see if [FAILED] in the startup
> messages. I see nothing in the log messages, syslog or dmesg. Is there a
> way to get more info on this?
>
> I can manually start my fetchmail using "service fetchmail start" after
> system is up and running and it works fine.
>
> -gene
>

Apparently a SELinux problem. Although fetchmail running as normal user 
it is forbidden from accessing files in user's ~ according to this 
bugzilla entry: https://bugzilla.redhat.com/show_bug.cgi?id=520765 .

So in /etc/init.d/fetchmail script I had to run fetchmail as
runcon -t unconfined_t fetchmail ...

So now it starts automatically on bootup.

I didn't expect this to be SELinux since I didn't see the "starfish".

fetchmail init script was sending error message to dev/null and when I 
removed that I saw in /var/log/boot.log that there were permission 
problem on fetchmail accessing the ~/.fetchmailrc files, which didn't 
make sense since fetchmail runs as user. This same script worked fine 
circa fc3 or 4.

-gene



-- 
users mailing list
[email protected]
To unsubscribe: https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux