Re: [Solved, kinda]Nvidia driver problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wednesday 26 August 2009 20:07:41 [email protected] wrote:
> Having already removed akmod-nvidia, I booted with kernel
> 2.6.29.6-217.2.3.fc11.x86_64, which was the only one still working and
> just did:
>
> yum remove kmod-nvidia*

What exactly did this remove? If I guess right, it removes kmod-nvidia drivers 
for *all* kernels (but I might be wrong). You can check that in 
/var/log/yum.log.

> yum install kmod-nvidia

This has installed the driver for the *currently running* kernel, if I am not 
mistaken again. So the one you have booted has the driver --- others don't.

> How those packages ever got to my system, I have no idea.

Maybe you can try

cat /var/log/yum.log* | grep "nvidia"

and see when those packages got installed, if your old yum logs are still 
there.

> Now, kernel 2.6.29.6-217.2.8 works, kernel 2.6.29.6-217.2.7 which never
> worked and I considered destroyed by my experiments with akmod, still
> doesn't work, and kernel 2.6.29.6-217.2.3, which always worked flawlessly,
> now doesn't work. Maybe, I should have booted to kernel 2.6.29.6-217.2.8
> and worked from a terminal for the remove/install operations, but I still
> find it strange that the .3 kernel, which always worked fine with the
> 185.18.14-3.fc11 Nvidia modules, doesn't work anymore with the same
> modules.

Each kernel needs to have its own set of nvidia modules. Yum will pick up and 
install only the ones for the running kernel. Once you have removed kmod-
nvidia* all modules for all kernels have been removed. In order to install 
appropriate modules for all kernels, boot into each one in turn and yum 
install kmod-nvidia, and that should do it for every particular kernel.

> Note that I got the boot message, that otherwise only flashes by, with the
> icon at the bottom of the login screen. It would have been impossible to
> read this message if the boot process had not terminated at the login
> screen. The "I" for interactive set-up has absolutely no effect and Shift
> pg-up doesn't get you to the previous boot messages screen. Those are not
> always present in dmesg or /var/log/messages and might prove helpful for
> troubleshooting.

cat /var/log/boot.log

in the konsole or xterm or whatever, and scroll to your heart's content using 
the scrollbars.

It could be a good idea to spend some time getting acquainted with the 
contents of /var/log directory. I mean, you didn't really think that the boot 
information does not get logged anywhere for later reference, or did you? 
Wasn't it natural to look in a place where basically all important logs are 
written? Doesn't the name "boot.log" look rather obvious?

Or have you never bothered to look what stuff is there in /var/log, other than 
/var/log/messages?

Also, Shift+PageUp works in the console terminal, although it keeps the buffer 
only for the last command executed, IIRC. I believe that the scroll buffer gets 
flushed once you get into the login prompt after boot (I am talking runlevel 3 
here), so Shift-PageUp doesn't work in that particular case. But it works 
otherwise, within the "last output only" rule. It has always been like that, 
AFAIK.

HTH, :-)
Marko

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux