Re: kernel 217.2.8 won't boot.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Markus Kesaromous wrote:

----------------------------------------
From: [email protected]
To: [email protected]
Date: Mon, 24 Aug 2009 11:09:19 -0600
Subject: kernel 217.2.8 won't boot.

Kernel 2.6.29.6-217.2.3.fc11.i586 works fine on my laptop, but 217.2.8
won't boot at all. It seems to run through everything just fine and
then the video starts blinking like crazy in text mode, like it can't
start the nvidia driver. After that I get a black screen with a
blinking cursor.

Kernel 217.2.3 is working OK for me. I can live without 217.2.8, except
that I am worried that the next kernel update will delete it and I might
be left with zero working kernels.

Any idea on what I could do to get 217.2.8 running ?

Thanks


$ uname -a
Linux localhost.localdomain 2.6.29.6-217.2.3.fc11.i586 #1 SMP Wed Jul 29
15:46:46 EDT 2009 i686 i686 i386 GNU/Linux

$ yum list kernel
Loaded plugins: dellsysidplugin2, downloadonly, kmdl, priorities,
refresh-packagekit
1 packages excluded due to repository priority protections
Installed Packages
kernel.i586 2.6.29.6-213.fc11 @updates
kernel.i586 2.6.29.6-217.2.3.fc11 @updates
kernel.i586 2.6.29.6-217.2.8.fc11 @updates

$ yum list \*nvidia*

Loaded plugins: dellsysidplugin2, downloadonly, kmdl, priorities,
refresh-packagekit
1 packages excluded due to repository priority
protections
Installed Packages

kmod-nvidia.i586 185.18.31-1.fc11 @rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-213.fc11.i586.i586 185.18.29-1.fc11
@rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-217.2.3.fc11.i586.i586 185.18.31-1.fc11
@rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-217.2.8.fc11.i586.i586 185.18.14-1.fc11.6
@rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.i586 185.18.31-1.fc11 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i586 185.18.31-1.fc11
@rpmfusion-nonfree-updates

Seems to me fedora kernel is screwing up more things than just video drivers which are supplied by xorg, but some of these drivers do not work on the fedora released kernel.

I am currently running FC11 2.6.29.6-217.2.8.fc11.i586 and my radeon driver from xorg seems to eork fine. However,  I wanted to see if I could
build and install latest 2.6.31-rc7 from kernel.org. Well, kernel configured and built and installed and booted just fine, but no gnome desktop because the radeon driver wont work on this kernel. Ditto with kernel 2.6.30.5
I think the answer is "from kernel.org" rather than "from rawhide" in this case. There were many changes in video with the 6.30 and 6.31 kernels, and I tried the rawhide one to fix my Intel video (did). But other things may have to change as well, so using the rawhide kernel is sometimes more successful that a raw kernel.org, particularly if you have custom modules tainting your kernel.
You might try doing that.

--
Bill Davidsen <[email protected]>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux