Re: Akmod-nvidia problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Tim:
>> I wasted ages TRYING to install, before then.


Jack:
> you are referring here to hdinstall,
> which was thoroughly discussed in these 3 refs:
> -----
> nov 2008 * F10 HD install - anyone successfully done this?
>          From: Mike Cloaked  and response by Tom Horsley
> 
> Bug 473351 - F10 HD install using the DVD iso file, initiated from grub, fails
> 
> View this message in context:
> http://www.nabble.com/F10-HD-install---anyone-successfully-done-this--tp20740373p20741211.html

Thanks for that, although that's a different technique than what I was
trying to do.  That method's more to do with putting your install files
onto the drive that you're going to install to, which wasn't possible
for me, and probably isn't going to - unless I make a huge boot
partition.  

And that'd still require a lot of effort - putting a laptop drive into
an external case (I don't have a spare one), putting the ISO file onto
the drive, putting the drive into the laptop...  Once you have a system
on a drive, i.e. it's not a new one, it's not so hard to prepare a drive
so that it has a large spare partition on it to hold install files
during installation, that wouldn't get messed with during the
installation.

The technique I wanted to follow, rather than messing with grub and
booting an install image through it, was one I'd used with prior
releases:

      * Download the DVD install ISO file onto an external drive using
        any available computer.
      * Attach that drive to the computer to be installed to.
      * Boot the netinstall disc.
      * Use the ask method install option.
      * Tell it where to find my DVD ISO file.
      * Start installing onto an empty brand new hard drive.

I've done that before, and it's far faster than installing from a DVD
(with slow seek speeds, spin up / spin down delays, and slower read
speed than a hard drive).  It was also less messing around, all one had
to do was ensure that the CD/DVD drive was the first boot device, to
boot the computer from the install disc (no writing of grub menus, no
trying to work out which drive was really sda, etc.).

Another alternative is to extract all the files from the ISO onto the
hard drive, and ask the installer to use the tree of files, rather than
the ISO.  That seems to work better on some systems, as they seem to die
under the load of dealing with a large ISO file.  And seems to be the
fastest method I've tried (install from the DVD, NFS install, HTTP
install, multi-CD-ROM install)...

In this instance, the biggest stumbling block seemed to be that the
install routine finds the external hard drive inaccessible (SATA drive
in a Seagate USB box).  It's presence was sort of noticed, to some
degree, but that was about it.  

Since I'm experimenting, I think I'll go through several tests, and
prepare this drive with either a large boot partition, or keep a spare
install partition to store the ISOs on.  I've been avoiding installing
updates, as I don't want to waste bandwidth and time, repeatedly
installing updates then throwing them away.

Incidentally, I tried installing both CentOS 5.3, then tried Fedora 11,
onto this laptop.  Both had issues with that external drive.  As I
recall, CentOS asked me to install a driver disc so it could try to
access the USB drive, but Fedora didn't.

> You possibly made a  mistake on where you placed the install.img.

Or, perhaps, the right install.img?  Should I extract one from the
netinstall ISO, or the DVD ISO?  Are they both the same thing?

> More likely is the need (starting in F10 and above)
> for a leading / on the directory holding the iso.

Possibly...  I had tried with and without leading slash, and likewise
with a trailing slash.  I really wish Linux would be consistent with
that (if it's a directory, end it with a slash, so we can easily tell
directory names from file names, and we don't overwrite files when we
mean to put a file into a directory).  And I really wish the installer
would be more helpful, if it needs a leading slash, then prompt for it,
and allow us some level of file system browsing instead of requiring us
to memorise filepaths.

> I need to reference that sda1 as sdb1
> because w usb  anaconda reorders the disks

Yes, I thought about that, and I think I did try telling the installer
to try both sda1 and sdb1, just in case.  It shouldn't happen, in my
case, because the boot sequence was first CD ROM, second internal hard
drive, no third option.

Getting back to the nvidia issue........

The default install, installed kernel-PAE-2.6.29.4-167.fc11.i686.  I
managed to miss seeing the PAE bit in there.  So I headed off trying to
install nvidia for the wrong kernel.

Seeing as I only have 1 gig of RAM, I didn't see any need for the PAE
kernel.  So I did a yum install kernel, and it fetched and installed
kernel-2.6.29.6-217.2.7.fc11.i586.  According to uname, I have a 686
CPU, and I thought the (something) "mistakeningly installs a 586,
instead of 686, kernel" was an old bug.

uname -a
Linux suspishus 2.6.29.6-217.2.7.fc11.i586 #1 SMP Fri Aug 14 20:41:20 EDT 2009 i686 i686 i386 GNU/Linux

Eventually, after also installing kernel-devel, myself, I get
akmod-nvidia to install and run.  And all is apparently well.  Though
I'm wondering about the i586 versus i686 business.

Before sorting out the 586/686 issue, I thought I'd see if I could get
nvidia working with the PAE kernel, even if I don't need it, since it's
already there to play with, and I'm sure I won't be the only person who
tries and fails to install it.  But no dice.  Something else is still
missing, I haven't figured that out yet, and the brain has gone on
strike trying to.

rpm -qa kernel\*|sort
kernel-2.6.29.6-217.2.7.fc11.i586
kernel-devel-2.6.29.6-217.2.7.fc11.i586
kernel-firmware-2.6.29.6-217.2.7.fc11.noarch
kernel-headers-2.6.29.6-217.2.7.fc11.i586
kerneloops-0.12-5.fc11.i586
kernel-PAE-2.6.29.4-167.fc11.i686
kernel-PAE-devel-2.6.29.6-217.2.7.fc11.i686
kernel-PAE-devel-2.6.29.6-217.2.8.fc11.i686

rpm -qa \*kernel\*|sort
akmod-nvidia-185.18.14-1.fc11.i686
kmod-nvidia-2.6.29.6-217.2.7.fc11.i586-185.18.14-1.fc11.i686
xorg-x11-drv-nvidia-185.18.14-3.fc11.i586
xorg-x11-drv-nvidia-libs-185.18.14-3.fc11.i586

And here's the /var/log/boot.log:

              Welcome to Fedora 
                Press 'I' to enter interactive startup.
Starting udev:                                             [  OK  ]
Setting hostname suspishus:                                [  OK  ]
mdadm: No arrays found in config file or automatically
Setting up Logical Volume Management:   2 logical volume(s) in volume group "vg_suspishus" now active
                                                           [  OK  ]
Checking filesystems
/dev/mapper/vg_suspishus-lv_root: clean, 141148/15122432 files, 2136364/60479488 blocks
/dev/sda1: clean, 40/51200 files, 28549/204800 blocks
                                                           [  OK  ]
Remounting root filesystem in read-write mode:             [  OK  ]
Mounting local filesystems:                                [  OK  ]
Enabling local filesystem quotas:                          [  OK  ]
Enabling /etc/fstab swaps:                                 [  OK  ]
Entering non-interactive startup
Checking kmods exist for 2.6.29.4-167.fc11.i686.PAE        [  OK  ]
Files needed for building modules against kernel
2.6.29.4-167.fc11.i686.PAE could not be found as the following
directories are missing:
/usr/src/kernels/2.6.29.4-167.fc11.i686.PAE/
/lib/modules/2.6.29.4-167.fc11.i686.PAE/build/             [FAILED]
Enabling ondemand cpu frequency scaling:                   [  OK  ]
ip6tables: Applying firewall rules:                        [  OK  ]
iptables: Applying firewall rules:                         [  OK  ]
Checking for module nvidia.ko:                             [FAILED]
nvidia.ko for kernel 2.6.29.4-167.fc11.i686.PAE was not fou[WARNING]
The nvidia driver will not be enabled until one is found.  [WARNING]
Driver already disabled.
Starting portreserve:                                      [  OK  ]
Starting system logger:                                    [  OK  ]
Starting irqbalance:                                       [  OK  ]
Starting rpcbind:                                          [  OK  ]
Starting NFS statd:                                        [  OK  ]
Starting RPC idmapd:                                       [  OK  ]
Starting system message bus:                               [  OK  ]
Starting cups:                                             [  OK  ]
Starting acpi daemon:                                      [  OK  ]
Starting HAL daemon:                                       [  OK  ]
Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]
Starting sshd:                                             [  OK  ]
Starting ntpd:                                             [  OK  ]
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]
Starting crond:                                            [  OK  ]
Starting atd:                                              [  OK  ]

So it boots up using the VESA driver if I select a PAE kernel in the
GRUB menu.  Booting the other 586 kernel uses the nvidia driver, built
by akmod, quite okay.


-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux