Re: conflicted file in update this morning?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 2009-08-03 at 09:04 -0700, Alan Evans wrote:
> Came to work this morning and updater icon told me that updates were
> available on my F11 system. Pretty routine, I told it to go ahead and
> do the update.
> 
> What wasn't routine was the subsequent error dialog complaining of
> "Local file conflict between packages":
> 
> Test Transaction Errors:   file
> /usr/share/X11/locale/el_GR.UTF-8/Compose from install of
> libX11-1.2.2-1.fc11.x86_64 conflicts with file from package
> libX11-1.2.1-2.fc11.i586
<snip>
> 
> The 32 and 64 bit packages have coexisted on my system for a long
> time. I don't even recall why I had the i586 package installed at all,
> but if I were to hazard a guess, I'd say that VMWare probably required
> the 32-bit libs.
> 
> Anyway, today I can't update. Can anything be done? Or should this get
> bugzilla'd? And if so, against what?
> 
> -Alan
> 

I had a similar problem, but with different packages, again for i586 and
x86_64. The i586 ones were installed for nswrapper, so I can use the
32-bit Adobe Flash plugin. All were language packs and I guess that the
architecture is irrelevant so the identical files appear in both
packages. Package-updater and yum both object to updating one without
the other but one has to go first...

I got round the problem by doing "yum update --tolerant". No problems
evident so far.

James

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux