Re: F10 Cups / Samba / Vista [SOLVED?]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Joel Gomberg wrote:
Craig White wrote:
On Wed, 2009-01-28 at 22:28 -0800, Joel Gomberg wrote:
Craig White wrote:
On Thu, 2009-01-29 at 12:08 +1030, Tim wrote:
On Wed, 2009-01-28 at 10:56 -0500, Brian C. Huffman wrote:
the alternative that someone suggested about just making it a network
printer and pointing to the http address for cups (bypassing samba)
does work. I'm just thinking that I might want to use this machine as a fileserver at some point and there's no need to use two points of entry if one works.
It's worth thinking about that putting Samba in between CUPS and remote
access to it, and you are putting an *extra* thing in the middle, *is*
complicating how printing works.
sure, when you're talking about one system.

also, experience tells me that things don't occur in isolation and
eventually you figure out that whatever is broken also affects other
things down the line that you haven't discovered yet.

The theory here is fairly simple...If cups is functioning properly,
computer can print. If samba is functioning properly, Windows computers
can print to samba shared printer through cups. Since PCL drivers on
Windows systems do not speak postscript, you must permit 'raw' printing
to allow the PCL through to the printer unmolested by cups. It really
isn't that complicated.
I've been experiencing a similar problem with my wife's new Vista computer. The printer is recognized. I can print a test page. Printing anything else has failed 99% of the time. The only relevant error I see in my cups error_log is:
cupsdAuthorize: No authentication data provided.
sounds as if you added...
        guest ok = yes
to the 'printers' section of smb.conf, this would go away though it
defies logic that you can print a test page from Windows but not from
other applications on Windows because of authentication.

Also, samba authentication is for Windows to samba and once samba has
the job, it should automatically authenticate itself to cups so it
doesn't make much sense for cups to complain about authentication.
The same setup worked on W2k and continues to work on a VMware W2k virtual machine. The relevant user has the same user name and password on both machines. Only printing is affected. Both computers can see the shares of the other. The shares can be mounted, files transferred, etc. This must be something Vista-specific. And, no, I can't explain why one or two jobs did print. I haven't posted about this issue before, because it doesn't really seem to be a Fedora problem.
There may be something Vista specific - I can't personally test because
I'm not eager to install Vista on any of my systems. I would suspect
that it's a Windows print driver issue.
That appears to be it. I opened the task manager and changed the
compatibility setting on all three running Epson driver processes from
Vista to XP Service Pack 2. [This is done by right-clicking on the
process, selecting "Properties" and then the Compatibility tab.]
Printing now works. Thanks for sharing your suspicion about the
underlying cause of the problem.
I'm replying to my own post, because the successful print was a one-time
anomaly. I do, now, however, seem to have found the problem. In Vista,
right-click on the printer, select properties -> advanced -> print processor.
In my case, there were two processors: Epson Inkjet and Winprint. I changed
the selection from Winprint to Epson Inkjet [raw] and I have now been able to
print several jobs in a row without any problems. My printer is an Epson Stylus
Photo R380. I haven't seen this documented anywhere. I just decided to look
more deeply at the printer properties after checking the Vista Event Viewer,
which suggested the driver was the problem.

fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux