Re: NetworkManager overwriting resolv.conf

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sat, 2009-01-17 at 20:39 +0200, Jonathan Dieter wrote:
> On Sat, 2009-01-17 at 11:10 -0700, Christopher A. Williams wrote:
> > I have been pulling my hair out over this, but seem to have a
> > work-around after a lot of searching, but I'd like to know if there's a
> > better way. Here's the info:
> > 
> > I'm building a server with F10 that (obviously) needs a static IP
> > address. It seems the best way to handle what's needed is to go ahead
> > and let NetworkManager still control the IP address.
> > 
> > BUT... I need to have that IP address activated at system startup, so it
> > must be configured via system-config-network as System eth0 (and eth1 in
> > this case) and then be controlled by NM.
> > 
> > Unfortunately, this machine - like most systems today - also needs DNS.
> > I'm running named as it's meant to be an internal local DNS server for a
> > bunch of other stuff too, but NM has a VERY nasty habit of
> > overwriting /etc/resolv.conf with something that's basically BLANK. So
> > every reboot, you have problems resolving DNS.
> You can tell NetworkManager which DNS servers to use, so that when it
> overwrites /etc/resolv.conf it does so with the correct information.
> If you've installed a GUI on your server, right click on NM, then Edit
> Connections.  Choose System ethX (where X is your interface number),
> then set the DNS servers to the ones you want.

I actually tried this. Unfortunately, apparently due to yet another NM
bug, these interfaces are shown as read only to NM. Thus it is
impossible to change the DNS info.

I also let NM create its own interfaces, which show up as "Auto eth0",
"Auto eth1", etc. You are able to feed these DNS information, but they
don't activate until you login, and they tend to de-activate upon

> If your server is text only,
> edit /etc/sysconfig/network-scripts/ifcfg-ethX, and add the lines
> and (where the x's are the IP
> addresses of your DNS servers; you could set it to if you're
> running named locally).

Tried this too. Unfortunately, NM didn't yet recognize something with
this (I think it's Peer DNS), so we apparently can't do it this way

I actually had tried all of this before posting for the first time. I
had already solved the problem well enough to do what was needed. I was
just looking for some indication of when this might get fixed. It's
clear that NM is the future direction of things. I'm just trying to get
myself used to it now...



"If you are calm while all around you is chaos,
then you probably haven't fully understood
the magnitude of the situation."


fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux