acpid daemon wont start after F8 -> F9 upgrade

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I upgraded my system from F8 -> F9.  When I boot the system I see an error regarding starting the acpid daemon.  When I restart it manually I see:

[[email protected] ~]# /etc/init.d/acpid restart
Stopping acpi daemon:                                      [FAILED]
Starting acpi daemon: acpid: can't open /proc/acpi/event: Device or resource busy
                                                          [FAILED]

When I run:

[[email protected] ~]# lsof /proc/acpi/event
COMMAND    PID      USER   FD   TYPE DEVICE SIZE       NODE NAME
hald-addo 2861 haldaemon    4r   REG    0,3    0 4026531960 /proc/acpi/event

And ps shows:

[[email protected] ~]# ps axlw | grep hald
5    68  2767     1  20   0  30468  5224 sys_po Ss   ?          0:00 hald
0     0  2771  2767  20   0  17836  1092 sys_po S    ?          0:00 hald-runner
0     0  2854  2771  20   0  19952  1016 sys_po S    ?          0:00 hald-addon-input: Listening on /dev/input/event1 /dev/input/event0 /dev/input/event6 /dev/input/event13 /dev/input/event3
4    68  2861  2771  20   0  12456   852 acpi_b S    ?          0:00 hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
0     0  2900  2771  20   0  19948   992 sys_po S    ?          0:00 hald-addon-storage: polling /dev/sr0 (every 2 sec)
0     0 12021 11717  20   0    316    92 sync_p D+   pts/8      0:00 grep hald

So how do I fix this so that acpid starts correctly on boot?

Thanks,
Paolo



-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux