Re: how to mount an lvm (thumb) drive?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Nov 25, 2008 at 3:39 PM, Chris Tyler <[email protected]> wrote:
>
>> > "mount /dev/<vgname>/<logvolname>  /mnt/anymountpoint
>>
>> It demands -t.
>
> This usually indicates that there is no recognized filesystem on the
> block device (i.e., wrong or empty block device).

Hmmm, well it was bootable the last time I tried.

>> [[email protected] ~]# mount  /dev/VolGroup00/LogVol01 test2
>> /dev/mapper/VolGroup00-LogVol01 looks like swapspace - not mounted
>> mount: you must specify the filesystem type
>
> I'm guessing that both the USB drive and your system have VolGroup00 as
> the volume group name, which is causing confusion.

Guessing that's the problem, or that they have the same name? They do
have the same name,

lvm lvs
 LV       VG         Attr   LSize   Origin Snap%  Move Log Copy%  Convert
 LogVol00 VolGroup00 -wi-ao 230.66G
 LogVol01 VolGroup00 -wi-ao   1.94G

and the man page says that is bad.

>Try renaming one of
> them using vgrename (carefully :-)

So... define 'carefully'. How do I make sure I am renaming the thumb
drive, not my hard drive, since they have the same name?

Okay, vgrename gives a hint, I need to figure out the UUID.

sudo lvm  lvs -v
    Finding all logical volumes
  LV       VG         #Seg Attr   LSize   Maj Min KMaj KMin Origin
Snap%  Move Copy%  Log Convert LV UUID
  LogVol00 VolGroup00    1 -wi-ao 230.66G  -1  -1 253  0
                           MI5Snb-QA02-67Ny-IK4t-iOg9-DPrT-SHlGEw
  LogVol01 VolGroup00    1 -wi-ao   1.94G  -1  -1 253  1
                           7uMx6B-KfGU-m9nk-Vqvw-JMnw-3s0m-LhwwBZ


[[email protected] ~]$ sudo vgrename 7uMx6B-KfGU-m9nk-Vqvw-JMnw-3s0m-LhwwBZ VolGroup01
  Volume group 7uMx6B-KfGU-m9nk-Vqvw-JMnw-3s0m-LhwwBZ not found.

Seems like that should've worked, here's the example from the man page:
"vgrename Zvlifi-Ep3t-e0Ng-U42h-o0ye-KHu1-nl7Ns4 VolGroup00_tmp"

So I am stumped. Maybe the thumb drive is goofy.

If I did manage to rename it, would that screw it up next time I boot from it?

Dave

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux