Re: How to get sound working in F9

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Waleed Harbi wrote:
What is your sound card?
try use *alsamixer *command.

On Tue, Nov 11, 2008 at 3:51 PM, GN <[email protected] <mailto:[email protected]>> wrote:
    Hi,

    Can someone please give me some clues on how to get sound working in F9.

    The System> Preferences > Hardware > Sound doesn't look anything like
    that shown in the help file and I am stymied.

    My /etc/PolicyKit/PolicyKit.conf file has me authed for everything.
    No errors show for pulseaudio --check

    Ta,

    GN
Hi Waleed,

Sound card is Intel Corp 82801H (ICH Family) HD Audio Controller (Rev 03)

/usr/bin/alsamixer gives 'No mixer elems found'.

Also, clicking on the volume contrtol gives the following:

The volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.
You can remove the volume control from the panel by right-clicking the
speaker icon on the panel and selecting "Remove From Panel" from the menu.
All the gstreamer packages that came with F9 are installed:

gstreamer-0.10.19-1.fc9.i386.rpm
gstreamer-plugins-base-0.10.19-2.fc9.i386.rpm
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.i386.rpm
gstreagstreamer-plugins-good-0.10.8-7.fc9.i386.rpm
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386.rpm
gstreamer-python-0.10.11-2.fc9.i386.rpm
gstreamer-tools-0.10.19-1.fc9.i386.rpm

This seems to indicate that no sound card has been configured. Fair enough.

dmesg says that the sound card has been found. dmesg | grep sound shows the following:
ALSA sound/pci/hda/hda_intel.c:1810: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x7
ALSA sound/pci/hda/hda_codec.c:2857: autoconfig: line_outs=1 (0x1a/0x0/0x0/0x0/0x0) ALSA sound/pci/hda/hda_codec.c:2861: speaker_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2865:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2866:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:2874: inputs: mic=0x18, fmic=0x19, line=0x0, fline=0x0, cd=0x0, aux=0x0 ALSA sound/pci/hda/hda_codec.c:2857: autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2861:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2865:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2866:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:2874: inputs: mic=0x0, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0 ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Mono Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Line-Out Playback Volume, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround Playback Switch, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center Playback Switch, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback Switch, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback Switch, skipped ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Mono Playback Switch, skipped ALSA sound/core/control.c:329: control 2:0:0:Front Playback Volume:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Front Playback Switch:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Headphone Playback Volume:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Headphone Playback Switch:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Mic Boost:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Front Mic Boost:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Capture Volume:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Capture Switch:0 is already present ALSA sound/core/control.c:329: control 2:0:0:Input Source:0 is already present ALSA sound/core/control.c:329: control 2:0:0:IEC958 Playback Con Mask:0 is already present.
I am well and truly confused. Does any of the above make sense to you?

Ta,

GN


--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux