Re: madwifi, F9, atheros 5413 cards

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


If someone can please help. same cards AR5413 (ar5006x) work with madwifi-0.9.4 on ubuntu but does not work on Fedora. I tried upgrading kernel too but still no luck.

ath5k which comes built in in F9 works with this card. Initially some howto mentioned to blacklist this module before loading madwifi's ath_pci. Isn't ath5k still in starting phase? Has someone tried to use it with ar5413 (ar5006x) cards?


On Mon, Oct 27, 2008 at 2:14 PM, PH mooraa <[email protected]> wrote:
Hi All,

reposting the question on this forum because I think the problem is with Fedora not madwifi

I am trying to use Adhoc mode with AR5413 card (5006 chipset) with following -

#uname -a
Linux localhost.localdomain 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT 2008 i686 athlon i386 GNU/Linux

There are 2 machines running F9/madwifi and having same cards in adhoc mode. (livna - madwifi-0.9.4-1.lvn9.i386, kmod-madwifi-0.9.4-31.lvn9.i686, kmod-madwifi-2.6.25-14.fc9.i686-0.9.4-31.lvn9.i686, madwifi-devel-0.9.4-1.lvn9.i386)

In adhoc mode, they associate with each other (same cell ID) but are not able to further communicate. ath0 interface created on top of wifi0 does not receive any packets but wifi0 do receive. I am not able to ping one from another. routes are set.

ath0      IEEE 802.11g  ESSID:"wmnad"  Nickname:"localhost.localdomain"
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:02:6F:51:77:3A  
          Bit Rate:0 kb/s   Tx-Power:15 dBm   Sensitivity=1/1 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=46/70  Signal level=-41 dBm  Noise level=-87 dBm
          Rx invalid nwid:7069  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ath0      Link encap:Ethernet  HWaddr 00:02:6F:51:77:3A 
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::202:6fff:fe51:773a/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:527 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:23013 (22.4 KiB)

wifi0     Link encap:UNSPEC  HWaddr 00-02-6F-51-77-3A-F4-AF-00-00-00-00-00-00-00-00 
          RX packets:233405 errors:0 dropped:0 overruns:0 frame:41464
          TX packets:18774 errors:25 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199
          RX bytes:33609299 (32.0 MiB)  TX bytes:1602695 (1.5 MiB)

On both machines ath0 RX packets remains 0 and I don't know why is this happening!!! Can someone please help..

I think that there no problems with ath_pci loading as can be seen -

ath_hal: module license 'Proprietary' taints kernel.
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.9.4
ath_pci: 0.9.4
ath_rate_sample: 1.2 (0.9.4)
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.4 phy 6.1 radio 6.3
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0xfdef0000, irq=18
ath0: no IPv6 routers present
ADDRCONF(NETDEV_UP): ath0: link is not ready
ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
ath0: no IPv6 routers present
ath0: no IPv6 routers present

My configuration file for interface is like -

#cat ifcfg-ath0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IWPRIV="authmode 1"

In last 3 lines, I overdid security because initially I thought the problem is due to authentication. I don't want any security at this point.

[ Other tests -
- the same card works in managed mode and connects to my building's WLAN AP. This makes me wonder more what I doing wrong.
- same cards with madwifi 0.9.4 works on Ubuntu in ad-hoc mode which shows that something in Fodora is going wrong. I really like F9 and really don't want to switch to ubuntu. ]

Any help is really appreciated.

Thanks in advance,

fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux