Re: After updating per instructions, does yum break?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dan Thurman wrote:
>
> I followed the instructions per:
> https://fedoraproject.org/wiki/Enabling_new_signing_key#Known_Issues
>
>
> So the steps were for me:
>
> 1) Get the Key: a) F8:
> http://kojipkgs.fedoraproject.org/packages/fedora-release/8/6.transition/data/signed/4f2a6fd2/noarch/fedora-release-8-6.transition.noarch.rpm
>
>
>
> b) F9:
> http://kojipkgs.fedoraproject.org/packages/fedora-release/9/5.transition/data/signed/4f2a6fd2/noarch/fedora-release-9-5.transition.noarch.rpm
>
>
>
> 2) rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-8-and-9 3) yum
> --skip-broken update 4) Wait until the yum package is fixed and
> added to the repository, then: a) yum update yum b) yum update
> yum-utils
>
> Is this right?
>
> But this looks like the chicken/egg problem...  yum is definitely
> broken after updates even if if the --skip-broken option is
> selected such as below:
>
> # yum --skip-broken list Traceback (most recent call last): File
> "/usr/bin/yum", line 29, in <module>
> yummain.user_main(sys.argv[1:], exit_code=True) File
> "/usr/share/yum-cli/yummain.py", line 243, in user_main errcode =
> main(args) File "/usr/share/yum-cli/yummain.py", line 98, in main
> base.getOptionsConfig(args) File "/usr/share/yum-cli/cli.py", line
> 183, in getOptionsConfig
> disabled_plugins=self.optparser._splitArg(opts.disableplugins))
> File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 180,
> in _getConfig startupconf.pluginconfpath,disabled_plugins) File
> "/usr/lib/python2.5/site-packages/yum/__init__.py", line 342, in
> doPluginSetup plugin_types, confpath, disabled_plugins) File
> "/usr/lib/python2.5/site-packages/yum/plugins.py", line 151, in
> __init__ self._importplugins(types) File
> "/usr/lib/python2.5/site-packages/yum/plugins.py", line 193, in
> _importplugins self._loadplugin(modulefile, types) File
> "/usr/lib/python2.5/site-packages/yum/plugins.py", line 226, in
> _loadplugin module = imp.load_module(modname, fp, pathname,
> description) File "/usr/lib/yum-plugins/filter-data.py", line 111
> ('committers', 'committer')] ^ SyntaxError: invalid syntax
>
> So, the question is - how do I fix this problem?
>
> Dan
>
hi,

you might want to just rpm -Uvh the latest yum from the
$basearch.newkey from d.f.r.c site. then a yum update should resolve
all... at least that worked for me.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAkjI0IIACgkQisV6fTFpwA2UpwCgofvCE73v03Xg0JzqE1Ghhtl0
O7YAn1TH5y0h4xSQx7O9paRiehr1mqId
=j9XL
-----END PGP SIGNATURE-----

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux