Re: install from not-the-first cdrom possible with kickstart?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I'm able to bypass the cd message using at boot
linux scd0=cdrom hda=none ks=hd:sdb/ks.cfg

but now I get the message telling if I want a driver disk.
Again, if I select Back the installation proceeds reading from the usb-scsi virtual cd.
Any chance to avoid/skip driver disk prompt?

On Mon, May 26, 2008 at 3:26 PM, Gianluca Cecchi <[email protected]> wrote:
I'm trying to install f8 (and tried with rh el 5 too) on a dell 1950.
I'm using virtual floppy (for kickstart file) and virtual cd (for dvd iso image), that are emulated as scsi over usb.
Onboard there is also a physical cd (seen as hda).
Virtual cd is seen initially as /dev/sr0 and then mapped by udev to /dev/scd0.
Virtual floppy is seen as /dev/sdb

I'm able to boot from virtual cd and at boot prompt I can type:

linux ks=hd:sdb/ks.cfg

so that my automated installation starts correctly using the kickstart file, where I have the lines:


During installation phase I get an error about not founding cdrom device.
At this point I can choose "back" in the screen and the installation proceeds automatically using the virtual cd.
Is there a way to tell ks (or in command line) to use automatically the virtual cd instead of the physical one?
I noticed that in ks docs there is:
cdrom — Install from the first CD-ROM drive on the system.

Is it the "first" word above causing me the problem?
I would like to have a completely unattanded installation path.... without necessarily pass through nfs or other network based installations?
I found suggestions about using idex=cdom at boot prompt and tried without success:

linux ks=hd:sdb/ks.cfg sr0=cdrom

linux ks=hd:sdb/ks.cfg scd0=cdrom


fedora-list mailing list
[email protected]
To unsubscribe:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux