Re: Another ssh problem-SOLVED

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 05Feb2008 05:12, Aaron Konstam <[email protected]xxxxxxxxxxxxx> wrote:
| On Tue, 2008-02-05 at 10:07 +1100, Cameron Simpson wrote:
| > On 04Feb2008 16:05, Aaron Konstam <[email protected]> wrote:
| > | I have 2 machines that are essentially F7 machines. From machine A I
| > | cannot sftp to machine B as myself. But sftp does work to Machine B if I
| > | am root. [...]
| > You would need to examine /var/log/secure on machineB for diagnostic
| > errors. I would guess directory or file permission problems.
| Your suggestion solved the problem and showed that I was nnot thinking
| straight. The answer was my laptop did not have a user olpc.
| When I sftp-ed to [email protected] it worked.
| I felt pretty stupid not to have not caught that. Thanks for setting me
| on the road to the solution.

It can sometimes be useful to embed the user in appropriate clause
in your machine A .ssh/config file when this happens. A weird example
for connecting to a machine console via a serial console server called

  Host swofford-console
    Hostname              hydra
    User                  cameron:ttyS1

which lets one go "ssh swofford-console".

I'd also remark that I usually turn off root ssh access to my machines.

Cameron Simpson <[email protected]> DoD#743

As a juror in a Trial by Jury, you have the right, power and duty to acquit
the defendant if you judge the law itself to be unjust.

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux