RE: x264 RPM installed/not installed

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


> Date: Tue, 5 Feb 2008 19:05:16 +0100
> From: [email protected]
> To: [email protected]
> Subject: Re: x264 RPM installed/not installed
> On 05/02/2008, Da Rock  wrote:
>>> On 05/02/2008, Da Rock  wrote:
>>>> Sounds strange huh?
>>>> I know I've been pesky with 3 threads on the run, but please bear with me.
>>>> I've just installed another repo based on info through the list - livna. Since then I've had some weird errors. The updater offers some 14 updates- which I wasn't able to update based on a missing file required:
>>>> So I ran a provides and whatprovides through the cmd yum and it says x264.i386 is to blame. I check if its installed through the software tool and yes it is. So I uninstall and try updating again: it works! But x264 is no longer installed. So I install x264.i386 - only this time its a livna rpm. It installs, but I check mplayer and only 1 option is installed, so no mencoder which is what I need. If I try to install it it says its still missing the shared object library.
>>>> I check again through yum and it says its installed- except its the freshrpms rpm version. Either way I can't get mencoder installed again.
>>>> Any ideas?
>>> In the list archives, Jan 29th, subject "‎, where art
>>> thou?" explains in what way livna and freshrpms conflict with regard
>>> to the x264 package.
>> Ok - thanks for the info, but is there no way to rectify the problem? A workaround even?
> It should be obvious if you understand the x264 problem and yum's
> error messages. Judging from your original message I think you
> misunderstand the problem. One work-around is to use either livna or
> freshrpms and keep that choice as long as the x264 packages are
> incompatible. Don't try to play tricks with --disablerepo= and
> --enablerepo= either. mencoder and mplayer are found at livna, too.
> -- 
> fedora-list mailing list
> [email protected]
> To unsubscribe:

Ok, I understand that, but the thing is that the updates just completed are from livna, so that includes mencoder and mplayer. And as I mentioned after uninstalling x264 with yum the livna package was installed for x264 so this should have solved the problem shouldn't it? So when I go checking to see what is installed via cmd yum I should see livna x264 installed shouldn't I? So why do I see the freshrpms one instead? Especially seeing as I uninstalled it!

I'll keep working on it - your info will help with this - and I'll post back a solution when I work it out.

Your Future Starts Here. Dream it? Then be it! Find it at

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux