gettext function not found by Perl module

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I need to install the gettext-1.05 perl module from CPAN because
some inherited , very obscure unmaintenable scripts I _need_ to run on FC8
64 bit need it.

When I run the perl Makefile.PL command, I get:

[[email protected] gettext-1.05]# perl Makefile.PL
checking for gettext... no
checking for gettext in -lintl... no
gettext function not found. Please install libintl at Makefile.PL line 18

but I don't know anymore where to find this libintl thing. After the first
time I got this error, I did:

yum install gettext
yum install perl-libintl
yum install perl-gettext
yum install libintl
yum install gettext-devel

and nothing changed, I still get that error. yum search libintl only returns:

perl-libintl.x86_64 : Internationalization library for Perl, compatible
with gettext

what else? I've even installed by hand the libintl-perl and
Locale::Maketext::Gettext modules from CPAN, and nothing changes, I still
get that error. What do I need to install to make it go away?

Thank you in advance for any feedback,


PS: if it helps, the error message comes from this piece of Makefile.PL:

unless (conftest("char *x = gettext(\"foo\");", "gettext", 0)) {
        # try with -lintl
        $libs = "-lintl";
        unless (conftest("char *x = gettext(\"foo\");", "gettext", 0)) {
                die "gettext function not found. Please install libintl";

Help *everybody* love Free Standards and Software:

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux