RE: [F8] Need help with tar or how to copy root to new drive?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Les Mikesell wrote:
> Daniel B. Thurman wrote:
> > I am having a hard time simply trying to copy my root 
> partition to a new
> > drive and somehow tar is not doing what I expected. Can 
> someone advise
> > me how to do it correctly?
> > 
> > I tried:
> > 
> > 1) mkdir /mnt/new
> > 2) mount /dev/sdc3 /mnt/new
> > 3) cd /mnt/new
> > 4) (cd /; tar --one-file-system --xattrs -cf - .) | tar 
> --one-file-system --xattrs -tvf -)
> >    [result: All mounted filesystems are copied over]  Drat!
> I think you have a typo somewhere.  The --one-file-system 
> option should 
>   keep tar from traversing mount points (and your -tvf option isn't 
> going to copy anything...)
> > The only other possibility that comes to my mind is to 
> mount the root drive
> > to /mnt/root read-only. mount the new drive to /mnt/new, 
> and then tar-copy
> > but this may have consequences with the currently mounted 
> root filesystem?
> If your drives are identical you can boot the install media 
> with 'linux 
> rescue' at the boot prompt, then use dd to copy the raw disk image.
> cp -a or rsync should work as well as tar for a file oriented 
> copy, and 
> both have --one-file-system options.

OK, I get it, it's me.  I should have followed what I wrote above
and it would have worked but somehow I also wanted the mount directories
included but I guess I cannot have it both ways.  Sigh.

What I was actually testing to get the mount directories only on
mounted filesystems was:

(cd /; tar --xattrs --one-file-system -cf - *) | tar -tvf -
and sure enough, the contents of the mounted filesystems were
included - which is not what I wanted.

BTW: Yes, the -tvf was intentional to show what I was gonna get
before committing the real action.

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux