Re: Wake On LAN on Fedora 7?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thursday, January 17, 2008, 12:23:08 AM, you wrote:

> Andrew Junev wrote on Wednesday 16 January 2008:

>> The problem is that the 'wake-on' parameter changes to 'd' (disabled)
>> when I shut the machine down, so WOL does not work.

> One problem I've seen is shutting down the NIC. When ifdown is executed,
> all WOL settings are lost. The solution is pretty easy: bring the card up
> just before the machine is powered off.

> Copy this snippet to /sbin/halt.local where it will be called 
> from /etc/init.d/halt on shutdown.

> #!/bin/sh
> ifconfig eth0 up
> ethtool -s eth0 wol g

> No changes to any files are required. YMMV. ;)

Ok, I triend this now.

I created a simple halt.local file. If I run it manually (without
shutting the system down), "Wake-on" is set to 'g' - that's correct!
But when I shut down the machine it does not power up with a "Magic
packet". And when I switch it on manually, I can see the Wake-on is
back to 'd' again. :-( 

I tried to implement a simple log file, so that I could see that
halt.local is actually running on shutdown. And now I know it is.
But 'Wake-on' still gets Disabled when the machine is powered down.

Here's my halt.local file:
# file: /sbin/halt.local
echo "halt.local started" > /tmp/halt.log
echo "Running ifconfig eth0 up" >> /tmp/halt.log
/sbin/ifconfig eth0 up
echo "Done. Now running ethtool -s eth0 wol g" >> /tmp/halt.log
/usr/sbin/ethtool -s eth0 wol g
echo "Done." >> /tmp/halt.log
sleep 5
echo "Slept for 5 seconds." >> /tmp/halt.log
echo "Script finished" >> /tmp/halt.log

Here's what I get in my /tmp/halt.log after a shutdown:
# cat /tmp/halt.log
halt.local started
Running ifconfig eth0 up
Done. Now running ethtool -s eth0 wol g
Slept for 5 seconds.
Script finished

What's wrong with my set-up???

Best regards,

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux