Re: Update problems!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Paul Johnson wrote:
Public key for yum-3.2.8-2.fc8.noarch.rpm is not installed
[[email protected] ~]#

What this means is there must be one public key missing and the dam
update fails.


Karl

You can find the missing keys on the Internet, but I expect they are
already in your computer.

In a Fedora 7 system, look in your system here:

/etc/pki/rpm-gpg

In there you see keys supplied with the system:

RPM-GPG-KEY              RPM-GPG-KEY-fedora-rawhide
RPM-GPG-KEY-adobe-linux  RPM-GPG-KEY-fedora-test
RPM-GPG-KEY-beta         RPM-GPG-KEY-livna
RPM-GPG-KEY-fedora       RPM-GPG-KEY-rawhide

You need to do

rpm --import RPM-GPG-KEY-fedora

After that, the yum install will work.

I don't have an F8 system booted up at the current time, but if the
keys are somewhere else, I'm sure you can find them with find (here's
how I found them: "find /etc -name "*RPM*KEY*".  I guess they might be
under /usr/share/doc/ instead of /etc.  On a Scientific Linux 5 system
I'm using now, they are under the doc directory.

What puzzles me is that this key is missing from your rpm database.
If it is not installed, it means you have never ever done a yum
update.  Which seems weird, given how old F8 is and how active you are
in this list.  And, usually yum will ask you if you want to install
the key, and you say yes, and the install proceeds.

Don't complain that pup or some other gui fails.  I've stopped using
them entirely.  Either download the rpms you need and use rpm commands
to install, or run yum from the command line.  It is the only way that
is either sure to work or give you enough information about what's
wrong in order to fix it.

yumex is the only gui RPM program I use anymore.  Sometimes it is
convenient if you need to search for RPMs by keywords..

I have had about 100+ updates to F8 and this is the first time I have had this problem. I can do the
rpm --import RPM-GPG-KEY-fedora

and will see what happens. If it works I pass it along.

Karl

What I get is

[[email protected] ~]# rpm --import RPM-GPG-KEY-fedora
error: RPM-GPG-KEY-fedora: import read failed(-1).


--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
GPG DF28 8F18 94F8 D5C6 9E44  163F 7FD1 3D06 C325 DA40


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux