FC8 Login Problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


My workstation is a Dell Optiplex 745.  I've got FC8 installed, yum'ed up and running pretty good with one exception.  I'm unable to login to this workstation using my enterprise userid.  This workstation lives in a computing environment where Windows is the normal desktop, but where Unix servers and Linux servers abound.  I am required to establish as the primary user account on this desktop machine, the very same userid I am assigned in the larger corporate world, which we'll call "corp".  So. once I install, I create a user account that I'll call "temp".  I'm supposed to use temp just long enough to get the machine configured and, using my desktop root authority, copy my enterprise /etc/passwd entry into my desktop /etc/passwd.  Along the way, I have to change the home directory listed in that entry according to how I've got it mounted to my desktop machine.  Thus, no matter if I'm on my desktop workstation, or logged onto any of a thousand servers, I'm still me and still using my own stuff.  Cool.  This worked just fine for me for a couple years with FC6.

However, I'm not able to login to my workstation using corp.  When the session manager gui comes up both temp and corp are listed.  I choose corp, give it my password, and then I get a dialog that I'll paraphrase as "Your home directory doesn't seem to exist.  Would you like to login as root?".

You'd think this was a simple problem of a bad mount, or a bad password, or some other finger check during the establishment of the desktop /etc/passwd entry.  But, I don't think that's the case.  When I login as temp, then start a shell, I can "su corp" just fine.  I'm fully me; with full access to the correct home directory.

I've poked all around the User and Groups dialog, gone through the /etc/passwd editing process very carefully three times, I'vd tried establishing several more user accounts on the desktop with complete success.  I've not been able to find anyt similar problems on the FC newsgroups.   I've check everything in /var/log/* for evidence of a mount problem...none exists.  I  did find this entry in /var/log/secure:

messages:Dec  6 14:08:18 mydesk gdm-binary[2340]: WARNING: gdm_slave_session_start: Home directory for corp: /remote/yada/yada/corp' does not exist!

I'm not even sure what kind of a problem this would be.  Is this a gdm problem?  Is it an authentication problem?  Is it sunspots?  I just wanna be me!

Thanks for your suggestions, Rosco

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux