Re: FC6 and

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Todd Zullinger wrote:
Tod wrote:
I recently installed subversion.  I wanted to start creating and
using a repository so I issued the svn command.  It failed due to
missing  I checked and it seems to belong to a
kerberos RPM.
Did you install from the Fedora rpm packages or from somewhere else?
The latest subversion for FC6 would appear to be 1.4.3-2.fc6.  That
rpm requires

$ rpm -qp --requires subversion-1.4.3-2.fc6.i386.rpm | grep libcom

Which is provided by e2fsprogs-libs:

$ rpm -q --whatprovides

Has anyone else run into this?
I haven't logged into my FC6 system in a few weeks or so, but svn
worked the last time I tried it, using what I believe to be the
current version.  It is possible some update since then has broken
things and I haven't noticed because I haven't logged in and updated
that system.

But I am curious to see if it isn't something I'm missing.  Its odd
that a RPM dependency would contain an older library.
I think something is amiss on your system, though I'm not sure what
that is.  Do any of the following commands report anything

$ rpm -q --requires subversion | grep libcom

$ rpm -V subversion

$ locate

$ rpm -q --whatprovides
no package provides

Also, what's the exact error you get when you run the svn command (and
the command you're running)?
forgot to do this, but from memory...

svn --help not found and is required - or something along those lines.

I also ran these:

rpm -qa|grep -i subv

ldd /usr/bin/svn =>  (0x0012b000) => /usr/local/lib/
(0x0012c000) => /usr/local/lib/ (0x00148000) => /usr/local/lib/ (0x00167000) => /usr/local/lib/
(0x0016a000) => /usr/local/lib/
(0x00170000) => /usr/local/lib/
(0x00174000) => /usr/local/lib/ (0x00188000) => /usr/local/lib/
(0x0018c000) => /usr/local/lib/
(0x001a0000) => /usr/local/lib/
(0x001bc000) => /usr/local/lib/
(0x001c9000) => /usr/local/lib/
(0x001da000) => /usr/local/lib/
(0x001e1000) => /usr/lib/ (0x00202000) => /lib/ (0x0021f000) => /usr/lib/ (0x0024d000) => /usr/lib/ (0x00287000) => /lib/ (0x00295000) => /usr/lib/ (0x0038c000) => /lib/ (0x003b4000) => /usr/lib/ (0x003cb000) => /lib/ (0x003ea000) => /lib/ (0x0042f000) => /usr/lib/ (0x00562000) => /usr/lib/ (0x0058d000) => /usr/lib/ (0x00615000) => /lib/ (0x0063b000) => /lib/ (0x0063e000) => /lib/ (0x00651000) => /lib/ (0x00655000) => /usr/lib/ (0x00676000) => /lib/ (0x00689000) => /usr/local/apr/lib/
(0x007c9000) => /usr/lib/ (0x007dd000) => /usr/local/apr/lib/ (0x007e4000) => /lib/ (0x00802000) => /lib/ (0x0080b000) => /lib/ (0x00832000) => /usr/local/lib/ (0x00849000) => not found => /usr/local/lib/ (0x0085f000) => /lib/ (0x00972000) => /usr/lib/ (0x00976000) => /usr/lib/ (0x00996000) => /usr/lib/ (0x009f5000)
        /lib/ (0x00110000) => /usr/lib/ (0x00a0e000) => not found

rpm -ql e2fsprogs-libs-1.39-7.fc6

sudo yum check-update returns nothing since I had just updated prior to that.

Thanks for your responding.  Sorry it took so long to report back.

- Tod

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux