[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Ralf Corsepius wrote:
> On Thu, 2007-06-14 at 09:26 +0200, antonio montagnani wrote:
>> When I try to upgrade kernel to latest update I get:
>>
>> Missing Dependency: mkinitrd >= 6.0.9-7.1 is needed by package kernel
>>
>> on my system I have mkinitrd-6.0.9-5
> I am having the opposite problem.
> 
> This morning's yum update upgraded the kernel despite it has broken
> deps:
> 
> # rpm -q --requires kernel-2.6.21-1.3228.fc7 | grep mkinitrd
> mkinitrd >= 6.0.9-7.1
> # rpm -q mkinitrd
> mkinitrd-6.0.9-5
> 
> => yum should have refused to update the kernel package, because the
> deps can't be satisfied:
> 
> # yum provides mkinitrd
> ...
> mkinitrd.i386                            6.0.9-5
> fedora          
> Matched from:
> mkinitrd
> ...
> mkinitrd.i386                            6.0.9-5
> installed       
> Matched from:
> Provides-match: mkinitrd
> 
> ... something is very much in limbo in yum-land :)
> 
> apt correctly refuses to upgrade:
> # apt-get upgrade
> ...
> kernel#2.6.21-1.3228.fc7: PreDepends: mkinitrd (>= 6.0.9-7.1)
> 
> Ralf
> 
> 

I tried updating two systems this morning.  One refused because it
required a newer mkinitrd than was available, the other went ahead,
despite there not being a newer mkinitrd.  Both are i686 systems, but
the one that succeeded still had a FC6 kernel on it (not used though,
and it was deleted by the update).

-- 
Sjoerd Mullender

Attachment: signature.asc
Description: OpenPGP digital signature


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux