[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



For the last few days or so, when I've attempted to perform a "yum
update", the process has consistently failed.  The most common error
is "[Error -1] Header is not complete", which is what I get after I
download all 100% of an RPM from an HTTP site.  When yum retries from
another mirror and the mirror happens to be an FTP site, I get other
errors (such as 500 RE*T not understood" or "500 Unknown command").

Poking around, I've seen an explanation for the "Header is not
complete" error that indicated that there is a problem with a proxy
server between me an the outside world.  While I won't rule that out,
I can say that I can use wget to fetch the rpm manually -- from a
cursory look, the RPM seems fine to me.

Any suggestions?

Yes, I've tried

$ sudo yum clean metadata

and

$ sudo yum clean all

Strangely, however

$ sudo yum clean cache

Returns an error:

Error: invalid clean argument: 'cache'

despite the fact that the man page claims "yum clean cache" should
work (and has worked in the past with older versions of yum).

If I were to fetch an RPM manually, could I verify that it is correct
somehow and then place it someplace at which yum would be happy with
it?

--wpd


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux