Re: OT: corrupted FATs on an external drive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



peter kostov wrote:
Hi,

I have a Samsung mp3 player that doesn't want to format his drive.
When I run fsck on it I get:

# fsck.vfat -rtlV -v /dev/sdb1
dosfsck 2.11 (12 Mar 2005)
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Checking we can access the last sector of the filesystem
Boot sector contents:
System ID "MSDOS5.0"
Media byte 0xf8 (hard disk)
      512 bytes per logical sector
     4096 bytes per cluster
        1 reserved sector
First FAT starts at byte 512 (sector 1)
        2 FATs, 16 bit entries
   126464 bytes per FAT (= 247 sectors)
Root directory starts at byte 253440 (sector 495)
      512 root directory entries
Data area starts at byte 269824 (sector 527)
    63127 data clusters (258568192 bytes)
63 sectors/track, 255 heads
       50 hidden sectors
   505550 sectors total
Starting check/repair pass.
Both FATs appear to be corrupt. Giving up.

I have tried mkdosfs with no luck.
I will appreciate very much if anyone can tell mi what to do to get it back to work.
Peter


If the mp3 player isn't working at all, try to check and see if you can change the drive partition(s). Doing this may fix the problem.
Also check to see if there is new software for the mp3 player as this
could fix the problem.
--
Due to the move to M$ Exchange Server,
   anything that is a priority, please phone.
Robin Laing


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux