Re: Yum Update not working [solved maybe]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12/3/06, Norm <[email protected]> wrote:
gary wrote:
> On Sat, 2006-12-02 at 22:30 -0800, Norm wrote:
>
>> I had to reinstall  Core 6.  Everything has gone well until I tried to
>> up date
>> At the command line if I try yum  update I get the following error
>> ftp://ftp.safe.ca/pub/clement-2.1/repodata/repomd.xml: [Errno 4]
>> IOError: [Errno ftp error] 550 Failed to change directory.
>> Trying other mirror.
>> Error: Cannot open/read repomd.xml file for repository: clement
>>  From the gui if I use the "software updater" I receive this error in an
>> "unable to retrieve information box "Cannot open/read repomd.xml file
>> for repository: clement"
>> I have yum updater enabled but it does not return any indication of
>> updates after I reboot the system.
>> When I go to the ftp site I notice that there seems to be a missing
>> subdirectory in the address between clement-2.1 and repodata. the ftp
>> site indicates there should be a "fc6" subdirectory.  The bottom is
>> there must be another way to do updates, what is it?
>> Norm
>>
>>
>>
>
>  Google - check this = http://forums.fedoraforum.org/showthread.php?t=139609
>          ----------gary
>
>
Thanks for the link, I think the problem may be solved.
When I reinstalled core 6 I decided to add a number of packages before I
did the update.  One of the packages was clement.  There was a reference
to clement causing the problem I had.  I decided to uninstal clement.
did a yum clean all and rebooted.  After the reboot it seemed to be
taking forever for the yum updater to do anything so I went to the
command line and gave yum  upgrade a try.  After a considerable period
the command line upgrade reported 147 packages to upgrade and the gnome
interface upgrade reported 113.  I have gone with the command line
upgrade and am now waiting for it to complete its process of installing
293 transaction.  At this point it all appears to be working.  I thought
I would give this method a try before I went to Kam's work around and
only as a last resort before another reinstall would I use Smart. The
last time I used Smart it destroyed my gnome setup and insisted that I
use KDE  -I thought using Linux was to give me choices - it seems Smart
does not believe in choices.
That is not smart's fault. Blame the KDE packager(s) for overwriting
/etc/sysconfig/desktop and replacing its contents with DESKTOP="KDE"
and DISPLAYMANAGER=KDE. The problem has happened to me many times when
I updated KDE. Hopefully, this behavior has ended.

Once things all up to-date and settled down I plan to try clement again
to see if the problem returns - I am not sure yet whether I should
describe the problem as a bug or just treat it as an incompatibility
between Yum and Clement.
Thanks for the help
Norm






[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux