AW: FreeNX on FC6 authentication problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I use for nx:

 

-yum install nx freenx

- install gnome kde or xfce(startup in nxclient with /usr/bin/startxfce4)

 

NX Config File::/etc/nxserver/node.conf

ENABLE_PERSISTENT_SESSION="all"

NX_LOG_LEVEL=6

NX_LOG_SECURE=1

NX_LOGFILE=/var/log/nxserver.log

SESSION_HISTORY=2592000

COMMAND_NETCAT=nc

SESSION_LOG_CLEAN=0

 

Define nxclient config and load /var/lib/nxserver/home/.ssh/client.id_dsa.key into nxclient as key

 

Ready.

 

Thomas


Von: [email protected] [mailto:[email protected]] Im Auftrag von Art Fore
Gesendet: Mittwoch, 15. November 2006 10:10
An: For users of Fedora
Betreff: Re: FreeNX on FC6 authentication problem

 

 

On 11/15/06, Craig White <[email protected]> wrote:

On Wed, 2006-11-15 at 12:16 +0800, Art Fore wrote:
>
>
> On 11/15/06, Craig White <[email protected]> wrote:
>         On Wed, 2006-11-15 at 10:58 +0800, Art Fore wrote:
>         >
>         >
>         > On 11/14/06, Dr. Michael J. Chudobiak <[email protected]>
>         wrote:
>         >
>         >
>         >         Art, here are some tips:
>         >
>         >         1) In the past, I found I had to run "passwd -uf nx"
>         to enable
>         >         the nx
>         >         user. The rpm didn't do it properly for some reason.
>         >
>         >         2) Make sure the client enables SSL encryption.
>         >
>         >         3) The rpm didn't uninstall properly, which really
>         messed
>         >         things up. If
>         >         you try to uninstall it, use rpm -evvv to get a
>         verbose output
>         >         to see
>         >         which files are causing trouble.
>         >
>         > Done the passwd -uf nx which reported success. SSL
>         encription is
>         > enabled. Still no luck. Client comes back with
>         > NX> 202 Authenticating user: nx
>         > NX> 208 Using auth method: publickey
>         > NX> 204 Authentication failed.
>         >
>         > Log file on server has Received signal 15, terminating.
>         >
>         > So, any further suggestions?
>         ----
>         get the file
>         /etc/nxserver/client.id_dsa.pub
>         from the server
>
>         paste it into the key on the client
>
> Copied the file to c:/documents and settings/art.fore/.ssh and .nx and
> to c:\program files\nx client for windows\share\keys. Now the client
> comes up with the same error, the server log only comes up with
> connection closed by MailScanner warning: numerical links are often
> malicious:10.18.31.29 (client IP address)
>
> What next?
----
keep failing until you follow instructions I would suppose

Craig

Well, I followed instructions as best I could given that they were rather sparse. I uninstalled everything and reinstaleld and started over with the website instractions mentioned earlier, which by the way have errors and got to the same point as before. I did find that importing the client.id_dsa.pub with the import button on the client, configure, general tab got me to where nx now authenticates, but now my login with my user name and password does not authenticate and I am using the correct name and password. What key or file controls this and how do I get nx to find it? is it one of the keys generated before? If so, which one? I am not at all clear on these keys as there is no real explanation of what is for what. (I also get the same thing from an nxclient on the server)

Art


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux