Re: KDE: 'safely remove' does not safely remove

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 2006-11-06 at 14:04 +0000, Paul Smith wrote:
> On 11/6/06, Craig White <[email protected]> wrote:
> > > > The option of "safely remove" for removing pen drives is not working
> > > > properly here. To safely remove my pen drive I have to use the command
> > > > line through the command 'umount /dev/sda1'. Any ideas how to repair
> > > > that?
> > >
> > > Do you wait for the pendrive icon vanishes from desktop or konqueror after
> > > clicking "safely remove"? It may take some time to flush the pending data
> > > write operations to the pendrive. It's safe to remove it only when the it's
> > > icon disappear (i.e., when it's automatically unmounted).
> > ----
> > that was it...OP has stated that it wasn't being automatically mounted
> > but rather a forced mount via entry in fstab
> 
> False: the problem was detected while automount option active. To
> circumvent the problem, I then forced mount via entry in fstab.
----
OK - I am unclear as to what processes you have gone through and when.

Expected behavior is for the user space auto mount when the USB pen
drive is inserted and for it to be unmounted when 'safely remove' is
chosen for that device. There should be no need to alter fstab or udev.

If that isn't the case, then the way to report this is through bugzilla
- http://bugzilla.redhat.com/bugzilla

Then the developers can actually test whether the problem is
reproducible or not.

Once you made the entry in fstab as noauto - then expected behavior is
altered.

Craig


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux