Re: FC4 -> FC5 upgrade gone awry

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 10/22/06, Monkey Pet <[email protected]> wrote:
I know this isn't supported, but I did it anyways telling myself that I
could get myself out of trouble if I got into trouble.  Here it is...

I tried to upgrade to FC4 -> FC5, using 'yum upgrade', and it seems to
succeeded after lots of brute force work resolving some broken dependencies
from 3rd party repos.  However, I know some packages did not upgrade.  The
system boots and is usable though.  I guess the root cause is that some 3rd
party repos packages had a higher version number than the one in fc5.  So
here is what I want:

1.   I want to make sure all packages installed are built for fc5.
2.   I want to check all packages and make sure they exist in the fc5 repos
mentioned in the yum.repos.d

I am wondering if someone has solved this problem with a script, if not I'll
be hacking away at it.
I don't have a pretty solution for your problem, but this command
should at least show you all the non-FC5 packages that you currently
have installed:
rpm -qa | grep -vi fc5


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
L. Friedman                                    [email protected]
LlamaLand                       http://netllama.linux-sxs.org


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux